summaryrefslogtreecommitdiffstats
path: root/network/SocksiPy
diff options
context:
space:
mode:
Diffstat (limited to 'network/SocksiPy')
-rw-r--r--network/SocksiPy/README3
-rw-r--r--network/SocksiPy/SocksiPy.SlackBuild76
-rw-r--r--network/SocksiPy/SocksiPy.info8
-rw-r--r--network/SocksiPy/setup.py13
-rw-r--r--network/SocksiPy/slack-desc19
5 files changed, 119 insertions, 0 deletions
diff --git a/network/SocksiPy/README b/network/SocksiPy/README
new file mode 100644
index 0000000000..56249d3a76
--- /dev/null
+++ b/network/SocksiPy/README
@@ -0,0 +1,3 @@
+This module was designed to allow developers of Python software that uses the
+Internet or another TCP/IP-based network to add support for connection through
+a SOCKS proxy server with as much ease as possible.
diff --git a/network/SocksiPy/SocksiPy.SlackBuild b/network/SocksiPy/SocksiPy.SlackBuild
new file mode 100644
index 0000000000..8aab767cee
--- /dev/null
+++ b/network/SocksiPy/SocksiPy.SlackBuild
@@ -0,0 +1,76 @@
+#!/bin/sh
+
+# Slackware build script for SocksiPy.
+#
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=SocksiPy
+VERSION=1.0.0
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="LICENSE README"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM.tar.gz -C $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Add setup.py
+cat $CWD/setup.py > setup.py
+
+python setup.py bdist
+tar zxvf dist/$PRGNAM-$VERSION.linux-i686.tar.gz -C $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/SocksiPy/SocksiPy.info b/network/SocksiPy/SocksiPy.info
new file mode 100644
index 0000000000..84d5f94af9
--- /dev/null
+++ b/network/SocksiPy/SocksiPy.info
@@ -0,0 +1,8 @@
+PRGNAM="SocksiPy"
+VERSION="1.0.0"
+HOMEPAGE="http://socksipy.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/socksipy/SocksiPy.tar.gz"
+MD5SUM="3be8be26230bc9eca94eb3335740ed5e"
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"
diff --git a/network/SocksiPy/setup.py b/network/SocksiPy/setup.py
new file mode 100644
index 0000000000..f8db7bca70
--- /dev/null
+++ b/network/SocksiPy/setup.py
@@ -0,0 +1,13 @@
+from distutils.core import setup
+
+import json
+
+setup(name="SocksiPy",
+ version="1.0.0",
+ description="SOCKS proxy server support module.",
+ author="Dan Haim",
+ author_email="negativeiq@users.sourceforge.net",
+ url = "http://socksipy.sourceforge.net/",
+ py_modules=['socks']
+ )
+
diff --git a/network/SocksiPy/slack-desc b/network/SocksiPy/slack-desc
new file mode 100644
index 0000000000..e380530d88
--- /dev/null
+++ b/network/SocksiPy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+SocksiPy: SocksiPy (SOCKS proxy server module)
+SocksiPy:
+SocksiPy: This module was designed to allow developers of Python software that
+SocksiPy: uses the Internet or another TCP/IP-based network to add support for
+SocksiPy: connection through a SOCKS proxy server with as much ease as possible.
+SocksiPy:
+SocksiPy:
+SocksiPy:
+SocksiPy:
+SocksiPy:
+SocksiPy: