summaryrefslogtreecommitdiffstats
path: root/network/deis/setup.patch
diff options
context:
space:
mode:
Diffstat (limited to 'network/deis/setup.patch')
-rw-r--r--network/deis/setup.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/network/deis/setup.patch b/network/deis/setup.patch
new file mode 100644
index 0000000000..51329d6938
--- /dev/null
+++ b/network/deis/setup.patch
@@ -0,0 +1,25 @@
+--- deis-1.6.0/setup.orig.py 2015-05-09 03:43:01.776728194 +0300
++++ deis-1.6.0/setup.py 2015-05-09 03:44:20.037749797 +0300
+@@ -2,6 +2,7 @@
+
+ """Install the Deis command-line client."""
+
++import os
+
+ try:
+ from setuptools import setup
+@@ -27,9 +28,11 @@
+ KWARGS = {'scripts': ['deis']}
+
+
+-with open('requirements.txt') as f:
+- required = f.read().splitlines()
+- required = [r for r in required if r.strip() and not r.startswith('#')]
++required = ""
++if os.path.isfile('requirements.txt'):
++ with open('requirements.txt') as f:
++ required = f.read().splitlines()
++ required = [r for r in required if r.strip() and not r.startswith('#')]
+
+
+ setup(name='deis',