summaryrefslogtreecommitdiffstats
path: root/network/fdm
diff options
context:
space:
mode:
Diffstat (limited to 'network/fdm')
-rw-r--r--network/fdm/GNUmakefile.patch34
-rw-r--r--network/fdm/README10
-rw-r--r--network/fdm/fdm.SlackBuild46
-rw-r--r--network/fdm/fdm.info2
-rw-r--r--network/fdm/fix_Makefiles.patch38
-rw-r--r--network/fdm/slack-desc18
6 files changed, 75 insertions, 73 deletions
diff --git a/network/fdm/GNUmakefile.patch b/network/fdm/GNUmakefile.patch
new file mode 100644
index 0000000000..ef9de2f6eb
--- /dev/null
+++ b/network/fdm/GNUmakefile.patch
@@ -0,0 +1,34 @@
+--- fdm-1,6/GNUmakefile 2008-12-22 21:50:05.000000000 +0530
++++ fdm-1.6/GNUmakefile 2009-05-09 19:07:21.000000000 +0530
+@@ -8,10 +8,7 @@
+
+ #DEBUG= 1
+
+-PREFIX?= /usr/local
+-
+-BIN_OWNER= bin
+-BIN_GROUP= root
++PREFIX?= /usr
+
+ CC= gcc
+
+@@ -27,8 +24,8 @@
+ endif
+
+ INSTALLDIR= install -d
+-INSTALLBIN= install -g $(BIN_OWNER) -o $(BIN_GROUP) -m 555
+-INSTALLMAN= install -g $(BIN_OWNER) -o $(BIN_GROUP) -m 444
++INSTALLBIN= install -m 0755
++INSTALLMAN= install -m 0644
+
+ SRCS= fdm.c \
+ attach.c buffer.c cleanup.c command.c connect.c io.c log.c netrc.c \
+@@ -72,7 +69,7 @@
+ endif
+
+ OBJS= $(patsubst %.c,%.o,$(SRCS))
+-CPPFLAGS+= $(DEFS) -I. -I- $(INCDIRS)
++CPPFLAGS+= $(DEFS) -I. -iquote. $(INCDIRS)
+ ifdef DEBUG
+ CFLAGS+= -g -ggdb -DDEBUG
+ LDFLAGS+= -rdynamic
diff --git a/network/fdm/README b/network/fdm/README
index e04c410099..a426739e87 100644
--- a/network/fdm/README
+++ b/network/fdm/README
@@ -1,12 +1,12 @@
fdm is a program to fetch mail and deliver it in various ways depending on a
-user-supplied ruleset. Mail may be fetched from stdin, IMAP or POP3 servers,
+user-supplied ruleset. Mail may be fetched from stdin, IMAP or POP3 servers,
or from local maildirs, and filtered based on whether it matches a regexp,
-its size or age, or the output of a shell command. It can be rewritten by
-an external process, dropped, left on the server or delivered into maildirs,
+its size or age, or the output of a shell command. It can be rewritten by
+an external process, dropped, left on the server, or delivered into maildirs,
mboxes, to a file or pipe, or any combination.
fdm is designed to be lightweight but powerful, with a compact but clear
-configuration syntax. It is primarily designed for single-user uses but may
-also be configured to deliver mail in a multi-user setup. In this case,
+configuration syntax. It is primarily designed for single-user uses but may
+also be configured to deliver mail in a multi-user setup. In this case,
it uses privilege separation to minimise the amount of code running as
the root user.
diff --git a/network/fdm/fdm.SlackBuild b/network/fdm/fdm.SlackBuild
index 2ff29539b1..a66bd13bf5 100644
--- a/network/fdm/fdm.SlackBuild
+++ b/network/fdm/fdm.SlackBuild
@@ -2,19 +2,33 @@
# Slackware build script for fdm
-# Written by Grigorios Bouzakis (grbzks@gmail.com)
+# Copyright 2007-2011 Grigorios Bouzakis <grbzks@xsmail.com>
+# All rights reserved.
+#
+# Permission to use, copy, modify, and distribute this software for any purpose
+# with or without fee is hereby granted, provided that the above copyright
+# notice and this permission notice appear in all copies.
+#
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES,
+# INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
+# FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+# AUTHORS AND COPYRIGHT HOLDERS AND THEIR CONTRIBUTORS BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=fdm
VERSION=${VERSION:-1.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -38,6 +52,8 @@ else
LIBDIRSUFFIX=""
fi
+DOCS="CHANGES MANUAL README TODO examples"
+
set -e
rm -rf $PKG
@@ -53,29 +69,19 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix up the Makefiles to not explicity declare owner and group when installing
-patch -p1 < $CWD/fix_Makefiles.patch
+patch -p1 < $CWD/GNUmakefile.patch
-make \
- PREFIX=/usr \
- CFLAGS+="$SLKCFLAGS" \
- CXXFLAGS+="$SLKCFLAGS"
-make install \
- PREFIX=/usr \
- DESTDIR=$PKG
+make CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS"
+make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES MANUAL README TODO examples \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/network/fdm/fdm.info b/network/fdm/fdm.info
index 6067015c07..cff45ce7b0 100644
--- a/network/fdm/fdm.info
+++ b/network/fdm/fdm.info
@@ -6,5 +6,5 @@ MD5SUM="b2b9bfe95217b290142bde1621eb9a37"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Grigorios Bouzakis"
-EMAIL="grbzks@gmail.com"
+EMAIL="grbzks@xsmail.com"
APPROVED="rworkman"
diff --git a/network/fdm/fix_Makefiles.patch b/network/fdm/fix_Makefiles.patch
deleted file mode 100644
index 0cf287c23e..0000000000
--- a/network/fdm/fix_Makefiles.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -Nur fdm-1.6.orig/GNUmakefile fdm-1.6/GNUmakefile
---- fdm-1.6.orig/GNUmakefile 2008-12-22 10:20:05.000000000 -0600
-+++ fdm-1.6/GNUmakefile 2009-01-16 23:57:52.922462755 -0600
-@@ -10,9 +10,6 @@
-
- PREFIX?= /usr/local
-
--BIN_OWNER= bin
--BIN_GROUP= root
--
- CC= gcc
-
- INCDIRS= -I$(PREFIX)/include
-@@ -27,8 +24,8 @@
- endif
-
- INSTALLDIR= install -d
--INSTALLBIN= install -g $(BIN_OWNER) -o $(BIN_GROUP) -m 555
--INSTALLMAN= install -g $(BIN_OWNER) -o $(BIN_GROUP) -m 444
-+INSTALLBIN= install -m 0755
-+INSTALLMAN= install -m 0644
-
- SRCS= fdm.c \
- attach.c buffer.c cleanup.c command.c connect.c io.c log.c netrc.c \
-diff -Nur fdm-1.6.orig/Makefile fdm-1.6/Makefile
---- fdm-1.6.orig/Makefile 2008-12-22 10:20:05.000000000 -0600
-+++ fdm-1.6/Makefile 2009-01-16 23:57:12.893462354 -0600
-@@ -94,8 +94,8 @@
-
- PREFIX?= /usr/local
- INSTALLDIR= install -d
--INSTALLBIN= install -g bin -o root -m 555
--INSTALLMAN= install -g bin -o root -m 444
-+INSTALLBIN= install -m 0755
-+INSTALLMAN= install -m 0644
-
- LDFLAGS+= -L/usr/local/lib
- .ifdef PROFILE
diff --git a/network/fdm/slack-desc b/network/fdm/slack-desc
index 4d82d6994e..d2936f6fc5 100644
--- a/network/fdm/slack-desc
+++ b/network/fdm/slack-desc
@@ -5,15 +5,15 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler----------------------------------------------------------|
fdm: fdm (simple, lightweight replacement for fetch/getmail type programs)
fdm:
-fdm: fdm is a program to fetch mail and deliver it in various ways
-fdm: depending on a user-supplied ruleset. Mail may be fetched from stdin,
-fdm: IMAP or POP3 servers, or from local maildirs, and filtered based on
-fdm: whether it matches a regexp, its ize or age, or the output of a shell
-fdm: command.It can be rewritten by an external process, dropped, left on
-fdm: the server or delivered into maildirs, mboxes, to a file or pipe, or
+fdm: fdm is a program to fetch mail and deliver it in various ways
+fdm: depending on a user-supplied ruleset. Mail may be fetched from stdin,
+fdm: IMAP or POP3 servers, or from local maildirs, and filtered based on
+fdm: whether it matches a regexp, its ize or age, or the output of a shell
+fdm: command.It can be rewritten by an external process, dropped, left on
+fdm: the server or delivered into maildirs, mboxes, to a file or pipe, or
fdm: any combination.
-fdm:
-fdm: Homepage: http://fdm.sourceforge.net/
+fdm:
+fdm: Homepage: http://fdm.sourceforge.net