summaryrefslogtreecommitdiffstats
path: root/network/flexget/flexget.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/flexget/flexget.SlackBuild')
-rw-r--r--network/flexget/flexget.SlackBuild39
1 files changed, 16 insertions, 23 deletions
diff --git a/network/flexget/flexget.SlackBuild b/network/flexget/flexget.SlackBuild
index 0ae5fc1484..f10b85810b 100644
--- a/network/flexget/flexget.SlackBuild
+++ b/network/flexget/flexget.SlackBuild
@@ -5,7 +5,7 @@
# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
# Copyright 2009-2010 Eric Hameleers, Eindhoven, Netherlands
# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Written by Lionel Young <redtricycle@gmail.com>
#
# All rights reserved.
@@ -28,13 +28,15 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# 20220515 46and2: Updated version, removed python2, New maintainer.
-# -still needs fixes before uploading
+# 20220908 46and2: Updated version.
+# -build process changed to fix issue with versions >3.3.20.
+# 20230915 46and2: Updated version, deps, various fixes.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=flexget
SRCNAM=FlexGet
-VERSION=${VERSION:-3.3.14}
+VERSION=${VERSION:-3.9.19}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -47,9 +49,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -59,20 +58,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -84,14 +69,22 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Remove versions from requirements
sed -i "s/==.*//" requirements.txt
-python3 setup.py install --root=$PKG
+# remove modules already included in python3.9 or win32
+sed -i -E -e '/^(backports-zoneinfo|pkgutil-resolve-name)/d' \
+ -e '/^(pywin32|win32-setctime)/d' requirements.txt
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION