summaryrefslogtreecommitdiffstats
path: root/network/gophernicus/gophernicus.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/gophernicus/gophernicus.SlackBuild')
-rw-r--r--network/gophernicus/gophernicus.SlackBuild33
1 files changed, 21 insertions, 12 deletions
diff --git a/network/gophernicus/gophernicus.SlackBuild b/network/gophernicus/gophernicus.SlackBuild
index 9414665e27..127c92b3a8 100644
--- a/network/gophernicus/gophernicus.SlackBuild
+++ b/network/gophernicus/gophernicus.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for Gophernicus
# Copyright 2012-2015 Fridrich von Stauffenberg <email removed>
-# Copyright 2018 B. Watson <yalhcru@gmail.com>
+# Copyright 2018 B. Watson <urchlay@slackware.uk>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,6 +23,7 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20210911 bkw: update for v3.1.1.
# 20180722 bkw:
# - Take over maintenance.
# - Update for latest upstream 'rolling release' version.
@@ -35,7 +36,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gophernicus
-VERSION=${VERSION:-2.5v101}
+VERSION=${VERSION:-3.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,9 +49,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,7 +77,7 @@ set -e
PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
+mkdir -p $TMP $PKG $OUTPUT $PKG/etc
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
@@ -87,15 +85,26 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . -perm /111 -exec chmod 755 {} + -o -exec chmod 644 {} +
-patch -p1 < $CWD/Makefile.patch
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfig=/etc/$PRGNAM \
+ --mandir=/usr/man \
+ --os=linux \
+ --listener=inetd,xinetd
-# 'make install' strips the binary already.
-make all CFLAGS="$SLKCFLAGS"
-make install DOCDIR="$PKGDOC" DESTDIR=$PKG
+make LDFLAGS="-lnsl"
+make install DESTDIR="$PKG"
-# Don't need this:
-rm -f $PKGDOC/INSTALL
+# binary already stripped
+gzip -9 $PKG/usr/man/man?/*.*
+# do not ship this!
+rm -rf $PKG/etc/inetd.conf
+
+mkdir -p $PKGDOC
+cp -a LIC* README* change* gophermap.sample gophertag $PKGDOC
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install