summaryrefslogtreecommitdiffstats
path: root/network/linksys-tftp/linksys-tftp-1.2.1-r1-Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'network/linksys-tftp/linksys-tftp-1.2.1-r1-Makefile.patch')
-rw-r--r--network/linksys-tftp/linksys-tftp-1.2.1-r1-Makefile.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/network/linksys-tftp/linksys-tftp-1.2.1-r1-Makefile.patch b/network/linksys-tftp/linksys-tftp-1.2.1-r1-Makefile.patch
new file mode 100644
index 0000000000..b374e808ec
--- /dev/null
+++ b/network/linksys-tftp/linksys-tftp-1.2.1-r1-Makefile.patch
@@ -0,0 +1,28 @@
+Fix LDFLAGS (bug http://bugs.gentoo.org/336956 ) and
+CFLAGS (bug http://bugs.gentoo.org/240894 ) by
+Michael Weber <xmw@gentoo.org>
+
+--- linksys-tftp-1.2.1/Makefile
++++ linksys-tftp-1.2.1/Makefile
+@@ -19,18 +19,18 @@
+ # We override /usr/include/arpa/tftp.h with our own because
+ # we want tu_block to be unsigned short, not short as on most platforms
+ #
+-CFLAGS= -I. -O2 -Dsin=sin_x
++CFLAGS += -I. -Dsin=sin_x
+ #DEBUG
+ # CFLAGS= -I. -Wall -ggdb -Dsin=sin_x
+ SRCS= main.c tftp.c tftpsubs.c
+ OBJS= main.o tftp.o tftpsubs.o
+ DOBJS= tftpsubs.o
+-CC= gcc
++CC?= gcc
+
+ all: linksys-tftp
+
+ linksys-tftp: ${OBJS}
+- ${CC} -o $@ ${CFLAGS} ${OBJS}
++ ${CC} -o $@ ${CFLAGS} ${OBJS} ${LDFLAGS}
+
+ clean:
+ rm -f ${OBJS} ${DOBJS} *core linksys-tftp