summaryrefslogtreecommitdiffstats
path: root/network/mod_wsgi/mod_wsgi.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/mod_wsgi/mod_wsgi.SlackBuild')
-rw-r--r--network/mod_wsgi/mod_wsgi.SlackBuild42
1 files changed, 35 insertions, 7 deletions
diff --git a/network/mod_wsgi/mod_wsgi.SlackBuild b/network/mod_wsgi/mod_wsgi.SlackBuild
index 2ec5084e98..cabcb80395 100644
--- a/network/mod_wsgi/mod_wsgi.SlackBuild
+++ b/network/mod_wsgi/mod_wsgi.SlackBuild
@@ -1,12 +1,32 @@
#!/bin/sh
-## Slackware build script for mod_wsgi
-##
-## Copyright 2008 Adis Nezirovic <adis _at_ linux.org.ba>
-## Licensed under GNU GPL v2
+# Slackware build script for mod_wsgi
+#
+# $Revision: f05ce16331b4 $
+# $Date: 2015/01/21 22:51:37 $
+#
+# Copyright 2008-2015 Adis Nezirovic <adis_at_linux.org.ba>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mod_wsgi
-VERSION=${VERSION:-3.4}
+VERSION=${VERSION:-4.4.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -36,7 +56,8 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+# Note: 4.x versions only have $VERSION in archive name
+tar xvf $CWD/$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -49,6 +70,13 @@ find -L . \
make
make install DESTDIR=$PKG
+# Enable EXPRESS builds using 'ENABLE_EXPRESS=1 ./mod_wsgi.SlackBuild'
+# For this you need pysetuptools and mod_wsgi-metrics, available from SBo
+# The express build creates it's own Apache module
+if [ ! -z $ENABLE_EXPRESS ];then
+ python setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
@@ -57,7 +85,7 @@ sed "s%@baselibdir@%lib${LIBDIRSUFFIX}%" $CWD/mod_wsgi.conf > \
$PKG/etc/httpd/extra/mod_wsgi.conf.new
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENCE README $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.Slackware
mkdir -p $PKG/install