summaryrefslogtreecommitdiffstats
path: root/network/modsecurity-apache/modsecurity-apache.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/modsecurity-apache/modsecurity-apache.SlackBuild')
-rw-r--r--network/modsecurity-apache/modsecurity-apache.SlackBuild36
1 files changed, 12 insertions, 24 deletions
diff --git a/network/modsecurity-apache/modsecurity-apache.SlackBuild b/network/modsecurity-apache/modsecurity-apache.SlackBuild
index 5a99ba2cc0..5bd982887b 100644
--- a/network/modsecurity-apache/modsecurity-apache.SlackBuild
+++ b/network/modsecurity-apache/modsecurity-apache.SlackBuild
@@ -5,11 +5,11 @@
# Written by pyllyukko
PRGNAM=modsecurity-apache
-VERSION=${VERSION:-2.6.8}
+VERSION=${VERSION:-2.7.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CRS_VERSION="2.2.6"
+CRS_VERSION="2.2.9"
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -65,25 +65,13 @@ cd $TMP
rm -rf ${PRGNAM}_${VERSION}
tar xvf $CWD/${PRGNAM}_${VERSION}.tar.gz
cd ${PRGNAM}_${VERSION}
-tar xvf $CWD/modsecurity-crs_${CRS_VERSION}.tar.gz
+tar xvf $CWD/${CRS_VERSION}.tar.gz
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix location of http module.
-# It's messy, actually, as the Makefile has a hardcoded libdir and also copies
-# the lib to the httpd/modules directory without using the DESTDIR, really
-# INSTALLing the library even when we only want to create a package :(
-sed \
- -e "/^pkglibdir/s|/lib|/lib${LIBDIRSUFFIX}|" \
- -e "s|\$(APXS_MODULES)|\$(DESTDIR)\$(APXS_MODULES)|" \
- -i apache2/Makefile.in
-# oh, and since it wanted to install locally, we need to manually create the
-# directory in the package...
-mkdir -p $PKG/$(apxs -q LIBEXECDIR)
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -95,21 +83,21 @@ make
make install-strip DESTDIR=$PKG
# It leaves two copies of the library, we'll only need one
-rm $PKG/usr/lib${LIBDIRSUFFIX}/*.so
+rm $PKG/usr/lib/*.so
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES LICENSE NOTICE README.TXT README_WINDOWS.TXT authors.txt doc/Reference_Manual.html \
+cp -a CHANGES LICENSE NOTICE README.TXT README_WINDOWS.TXT authors.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/etc/httpd/extra
cat modsecurity.conf-recommended > $PKG/etc/httpd/extra/modsecurity-recommended.conf.new
+cat unicode.mapping > $PKG/etc/httpd/extra/unicode.mapping
# The Core Rule Set
mkdir -p ${PKG}/etc/httpd/crs
-cp -Rv modsecurity-crs_${CRS_VERSION}/* ${PKG}/etc/httpd/crs
-cat modsecurity-crs_${CRS_VERSION}/modsecurity_crs_10_setup.conf.example > \
+cp -Rv owasp-modsecurity-crs-${CRS_VERSION}/* ${PKG}/etc/httpd/crs
+cat owasp-modsecurity-crs-${CRS_VERSION}/modsecurity_crs_10_setup.conf.example > \
${PKG}/etc/httpd/crs/modsecurity_crs_10_setup.conf.new
mkdir -p $PKG/install