summaryrefslogtreecommitdiffstats
path: root/network/nicotine+/nicotine+.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/nicotine+/nicotine+.SlackBuild')
-rw-r--r--network/nicotine+/nicotine+.SlackBuild46
1 files changed, 15 insertions, 31 deletions
diff --git a/network/nicotine+/nicotine+.SlackBuild b/network/nicotine+/nicotine+.SlackBuild
index 11928f1f5a..1605b0a550 100644
--- a/network/nicotine+/nicotine+.SlackBuild
+++ b/network/nicotine+/nicotine+.SlackBuild
@@ -1,19 +1,19 @@
#!/bin/sh
+
# Slackware build script for nicotine+
-# Written by Iskar Enev <iskar.enev[@]gmail.com>
+# Originally written by Iskar Enev <iskar.enev[@]gmail.com>
# Modified by the SlackBuilds.org project
+# Maintained as of version 1.2.16 by Audrius Kažukauskas <audrius@neutrino.lt>
PRGNAM=nicotine+
-VERSION=1.2.14
+VERSION=${VERSION:-1.2.16}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -23,7 +23,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-set -e
+set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -38,41 +38,25 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build
-python setup.py install --root $PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+python setup.py install --root=$PKG
mv $PKG/usr/share/man $PKG/usr
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
-( cd $PKG/usr/bin
- ln -s nicotine.py nicotine
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-# Contains duplicates from site-package so removing it
-rm -rf $PKG/usr/pynicotine
+( cd $PKG/usr/bin ; ln -sf nicotine.py nicotine )
-# Let's use the larger icon to ensure proper scaling
-sed -i 's%Icon=nicotine-plus-32px.png%Icon=nicotine-plus-96px.png%' \
+# Let's use the larger icon to ensure proper scaling.
+sed -i 's/Icon=nicotine-plus/Icon=nicotine-plus-96px/' \
$PKG/usr/share/applications/nicotine.desktop
-
-# Let's put these icons and such in a subdirectory of their own instead of
-# spamming /usr/share/pixmaps with all sorts of stuff
-rm $PKG/usr/share/pixmaps/*
-mkdir -p $PKG/usr/share/pixmaps/nicotine
-cp -a files/*.png img/*.png img/*.ico img/*.xcf img/README \
- $PKG/usr/share/pixmaps/nicotine
-cp -a $PKG/usr/share/pixmaps/nicotine/nicotine-plus-96px.png $PKG/usr/share/pixmaps
+rm -f $PKG/usr/share/pixmaps/*
+cp -a files/nicotine-plus-96px.png $PKG/usr/share/pixmaps
mkdir -p $PKG/usr/doc
-cp -a COPYING MANIFEST PKG-INFO $PKG/usr/share/nicotine/documentation
+cp -a COPYING $PKG/usr/share/nicotine/documentation
mv $PKG/usr/share/nicotine/documentation $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/nicotine-plus.SlackBuild
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc