summaryrefslogtreecommitdiffstats
path: root/network/nicotine+
diff options
context:
space:
mode:
Diffstat (limited to 'network/nicotine+')
-rw-r--r--network/nicotine+/README14
-rw-r--r--network/nicotine+/doinst.sh2
-rw-r--r--network/nicotine+/nicotine+.SlackBuild46
-rw-r--r--network/nicotine+/nicotine+.info8
-rw-r--r--network/nicotine+/slack-desc18
5 files changed, 36 insertions, 52 deletions
diff --git a/network/nicotine+/README b/network/nicotine+/README
index 4d1d7fc0be..f47b2d22c2 100644
--- a/network/nicotine+/README
+++ b/network/nicotine+/README
@@ -1,11 +1,11 @@
-Nicotine+ is a client for the SoulSeek filesharing network. It was "forked"
-from Nicotine, Hyriand's Soulseek client, which in turn was forked from the
+Nicotine+ is a client for the SoulSeek filesharing network. It was "forked"
+from Nicotine, Hyriand's Soulseek client, which in turn was forked from the
PySoulSeek project by Alexander Kanavin.
-Optional (available at SlackBuilds.org):
-* GeoIP python bindings (Country lookup)
-* Mutagen
-* Psyco (speeds up Python code, but doesn't work on x86_64)
+Optional (available at SlackBuilds.org):
+* GeoIP-Python
+* mutagen
+* sexy-python
Optional (not available at SlackBuilds.org, but submissions are welcome):
-* PyOGG http://ekyo.nerim.net/software/pyogg/
+* miniupnpc
diff --git a/network/nicotine+/doinst.sh b/network/nicotine+/doinst.sh
index 392c12adb9..4e8ba7071d 100644
--- a/network/nicotine+/doinst.sh
+++ b/network/nicotine+/doinst.sh
@@ -1,4 +1,4 @@
if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
diff --git a/network/nicotine+/nicotine+.SlackBuild b/network/nicotine+/nicotine+.SlackBuild
index 11928f1f5a..1605b0a550 100644
--- a/network/nicotine+/nicotine+.SlackBuild
+++ b/network/nicotine+/nicotine+.SlackBuild
@@ -1,19 +1,19 @@
#!/bin/sh
+
# Slackware build script for nicotine+
-# Written by Iskar Enev <iskar.enev[@]gmail.com>
+# Originally written by Iskar Enev <iskar.enev[@]gmail.com>
# Modified by the SlackBuilds.org project
+# Maintained as of version 1.2.16 by Audrius Kažukauskas <audrius@neutrino.lt>
PRGNAM=nicotine+
-VERSION=1.2.14
+VERSION=${VERSION:-1.2.16}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -23,7 +23,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-set -e
+set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -38,41 +38,25 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build
-python setup.py install --root $PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+python setup.py install --root=$PKG
mv $PKG/usr/share/man $PKG/usr
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
-( cd $PKG/usr/bin
- ln -s nicotine.py nicotine
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-# Contains duplicates from site-package so removing it
-rm -rf $PKG/usr/pynicotine
+( cd $PKG/usr/bin ; ln -sf nicotine.py nicotine )
-# Let's use the larger icon to ensure proper scaling
-sed -i 's%Icon=nicotine-plus-32px.png%Icon=nicotine-plus-96px.png%' \
+# Let's use the larger icon to ensure proper scaling.
+sed -i 's/Icon=nicotine-plus/Icon=nicotine-plus-96px/' \
$PKG/usr/share/applications/nicotine.desktop
-
-# Let's put these icons and such in a subdirectory of their own instead of
-# spamming /usr/share/pixmaps with all sorts of stuff
-rm $PKG/usr/share/pixmaps/*
-mkdir -p $PKG/usr/share/pixmaps/nicotine
-cp -a files/*.png img/*.png img/*.ico img/*.xcf img/README \
- $PKG/usr/share/pixmaps/nicotine
-cp -a $PKG/usr/share/pixmaps/nicotine/nicotine-plus-96px.png $PKG/usr/share/pixmaps
+rm -f $PKG/usr/share/pixmaps/*
+cp -a files/nicotine-plus-96px.png $PKG/usr/share/pixmaps
mkdir -p $PKG/usr/doc
-cp -a COPYING MANIFEST PKG-INFO $PKG/usr/share/nicotine/documentation
+cp -a COPYING $PKG/usr/share/nicotine/documentation
mv $PKG/usr/share/nicotine/documentation $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/nicotine-plus.SlackBuild
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/network/nicotine+/nicotine+.info b/network/nicotine+/nicotine+.info
index 24ae005380..9c535e6ef9 100644
--- a/network/nicotine+/nicotine+.info
+++ b/network/nicotine+/nicotine+.info
@@ -1,10 +1,10 @@
PRGNAM="nicotine+"
-VERSION="1.2.14"
+VERSION="1.2.16"
HOMEPAGE="http://nicotine-plus.org/"
-DOWNLOAD="http://129.125.101.92/nicotine+/nicotine+-1.2.14.tar.bz2"
-MD5SUM="c43dfbd8e759d0228fa9d1e0525cf993"
+DOWNLOAD="http://129.125.101.92/nicotine+/nicotine+-1.2.16.tar.bz2"
+MD5SUM="ac7433c21ef619a37e079a7ae68da94a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Audrius Kažukauskas"
EMAIL="audrius@neutrino.lt"
-APPROVED="Erik Hanson"
+APPROVED="Niels Horn"
diff --git a/network/nicotine+/slack-desc b/network/nicotine+/slack-desc
index 3a797f5f2b..04ef0c8b5b 100644
--- a/network/nicotine+/slack-desc
+++ b/network/nicotine+/slack-desc
@@ -1,19 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
- |-----handy-ruler---------------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
nicotine+: Nicotine+ (SoulSeek client written in Python)
nicotine+:
nicotine+: Nicotine+ is a SoulSeek client written in Python, based on the
-nicotine+: PySoulSeek project by Alexander Kanavin. It features, among other
+nicotine+: PySoulSeek project by Alexander Kanavin. It features, among other
nicotine+: things, a completely rewritten graphical user interface which
-nicotine+: uses the PyGTK-2 toolkit and a less strict user request policy.
-nicotine+: Nicotine-Plus is a fork of Hyriand's original Nicotine Soulseek client.
-nicotine+:
+nicotine+: uses the PyGTK-2 toolkit and a less strict user request policy.
+nicotine+: Nicotine+ is a fork of Hyriand's original Nicotine Soulseek client.
+nicotine+:
nicotine+: NOTE: these code changes are NOT sanctioned by Hyriand, so if this
nicotine+: messes you up, don't bug him.
nicotine+: