summaryrefslogtreecommitdiffstats
path: root/network/privoxy/privoxy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/privoxy/privoxy.SlackBuild')
-rw-r--r--network/privoxy/privoxy.SlackBuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/network/privoxy/privoxy.SlackBuild b/network/privoxy/privoxy.SlackBuild
index 576e2a5184..e3f72e6e05 100644
--- a/network/privoxy/privoxy.SlackBuild
+++ b/network/privoxy/privoxy.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for privoxy
# Copyright (c) 2007 alkos333 <me@alkos333.net>
-# Copyright 2014-2019 Kyle Guinn <elyk03@gmail.com>
+# Copyright 2014-2021 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=privoxy
-VERSION=${VERSION:-3.0.28}
+VERSION=${VERSION:-3.0.32}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -89,17 +89,14 @@ chmod -R u+w,go-w,a+rX-st .
# Put the docs where we tell them to go.
sed -i "/^DOC_DEST/s/= .*/= @docdir@/" GNUmakefile.in
-# The Makefile checks if certain config files exist, and if so, adds a
-# .new suffix. Turn this behavior off. We will do it below.
-sed -i "s/\[ -s \"\$(CONF_DEST)\/\$\$i\" \]/false/" GNUmakefile.in
-
# rc.privoxy generation doesn't work well with $(DESTDIR). Help it along.
sed -i "s/ \/etc\/rc.d\// \$(DESTDIR)\/etc\/rc.d\//g" GNUmakefile.in
mkdir -p $PKG/etc/rc.d
-autoheader
-autoconf
-CFLAGS="$SLKCFLAGS" \
+# Let AC_CHECK_LIB do the brotli autodetection, don't link to it if missing.
+sed -i "/-lbrotlidec/d" configure.in
+
+autoreconf -vif
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@@ -112,9 +109,14 @@ CFLAGS="$SLKCFLAGS" \
--with-docbook=no \
--with-user=$PRIVOXY_USER \
--with-group=$PRIVOXY_GROUP \
+ --with-openssl \
+ --with-brotli \
--enable-no-gifs \
--enable-compression \
- --enable-large-file-support
+ --enable-large-file-support \
+ --enable-extended-statistics \
+ --enable-pcre-host-patterns \
+ CFLAGS="$SLKCFLAGS" \
make
make install-strip DESTDIR=$PKG