summaryrefslogtreecommitdiffstats
path: root/network/qutebrowser/qutebrowser.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/qutebrowser/qutebrowser.SlackBuild')
-rw-r--r--network/qutebrowser/qutebrowser.SlackBuild30
1 files changed, 5 insertions, 25 deletions
diff --git a/network/qutebrowser/qutebrowser.SlackBuild b/network/qutebrowser/qutebrowser.SlackBuild
index e42eec6390..206fcd5b5b 100644
--- a/network/qutebrowser/qutebrowser.SlackBuild
+++ b/network/qutebrowser/qutebrowser.SlackBuild
@@ -23,7 +23,7 @@
PRGNAM=qutebrowser
VERSION=${VERSION:-2.0.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -39,20 +39,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -68,20 +54,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-make -f misc/Makefile install DESTDIR=$PKG PREFIX=/usr
+make -f misc/Makefile install DESTDIR=$PKG PREFIX=/usr MANDIR=/usr/man
find $PKG -name \*\.opt-1.pyc -exec rm -f {} \;
-mkdir -p $PKG/usr/share/pixmaps
-cp icons/qutebrowser.xpm $PKG/usr/share/pixmaps/
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mv $PKG/usr/share/man $PKG/usr
+install -D -m 0644 icons/qutebrowser.xpm \
+ $PKG/usr/share/pixmaps/qutebrowser.xpm
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man1/qutebrowser.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.asciidoc $PKG/usr/doc/$PRGNAM-$VERSION