summaryrefslogtreecommitdiffstats
path: root/network/qutebrowser/qutebrowser.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/qutebrowser/qutebrowser.SlackBuild')
-rw-r--r--network/qutebrowser/qutebrowser.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/network/qutebrowser/qutebrowser.SlackBuild b/network/qutebrowser/qutebrowser.SlackBuild
index 10499c7d78..946e53a66e 100644
--- a/network/qutebrowser/qutebrowser.SlackBuild
+++ b/network/qutebrowser/qutebrowser.SlackBuild
@@ -22,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=qutebrowser
-VERSION=${VERSION:-1.0.4}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -61,7 +61,7 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-cp $CWD/Makefile .
+sed -i 's/testbrowser_cpp/testbrowser/' misc/Makefile
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-make install DESTDIR=$PKG
+make -f misc/Makefile install DESTDIR=$PKG
find $PKG -name \*\.opt-1.pyc -exec rm -f {} \;