summaryrefslogtreecommitdiffstats
path: root/network/qutebrowser/qutebrowser.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/qutebrowser/qutebrowser.SlackBuild')
-rw-r--r--network/qutebrowser/qutebrowser.SlackBuild28
1 files changed, 7 insertions, 21 deletions
diff --git a/network/qutebrowser/qutebrowser.SlackBuild b/network/qutebrowser/qutebrowser.SlackBuild
index c0eef5181c..66a1688230 100644
--- a/network/qutebrowser/qutebrowser.SlackBuild
+++ b/network/qutebrowser/qutebrowser.SlackBuild
@@ -1,31 +1,14 @@
#!/bin/bash
# Slackware build script for qutebrowser
-# Copyright 2017 Dave Woodfall <dave@slackbuilds.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# written by Dave Woodfall <dave@slackbuilds.org>
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=qutebrowser
-VERSION=${VERSION:-2.2.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.5.4}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,6 +49,9 @@ find -L . \
make -f misc/Makefile install DESTDIR=$PKG PREFIX=/usr MANDIR=/usr/man
+# shouldn't be executable
+chmod -x $PKG/usr/share/$PRGNAM/userscripts/README.md
+
find $PKG -name \*\.opt-1.pyc -exec rm -f {} \;
install -D -m 0644 icons/qutebrowser.xpm \