summaryrefslogtreecommitdiffstats
path: root/network/razor-agents/makefile_quoted_vars.diff
diff options
context:
space:
mode:
Diffstat (limited to 'network/razor-agents/makefile_quoted_vars.diff')
-rw-r--r--network/razor-agents/makefile_quoted_vars.diff13
1 files changed, 13 insertions, 0 deletions
diff --git a/network/razor-agents/makefile_quoted_vars.diff b/network/razor-agents/makefile_quoted_vars.diff
new file mode 100644
index 0000000000..1099e9f18c
--- /dev/null
+++ b/network/razor-agents/makefile_quoted_vars.diff
@@ -0,0 +1,13 @@
+Recent MakeMaker versions quote variables.
+diff -ur razor-agents-2.85.orig/Makefile.PL razor-agents-2.85/Makefile.PL
+--- razor-agents-2.85.orig/Makefile.PL 2007-05-09 00:47:53.000000000 +0200
++++ razor-agents-2.85/Makefile.PL 2015-08-19 06:35:39.000000000 +0200
+@@ -142,7 +142,7 @@
+ my $man5 = q{ \\
+ $(INST_MAN5DIR) $(INSTALLMAN5DIR)};
+
+- $inherited =~ s/(\$\((?:DEST)?INSTALL\w*MAN1DIR\))/$1$man5/gm;
++ $inherited =~ s/(\$\((?:DEST)?INSTALL\w*MAN1DIR\)"?)/$1$man5/gm;
+
+ return $inherited;
+ }