summaryrefslogtreecommitdiffstats
path: root/network/scapy/scapy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/scapy/scapy.SlackBuild')
-rw-r--r--network/scapy/scapy.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/network/scapy/scapy.SlackBuild b/network/scapy/scapy.SlackBuild
index 2b15e78e53..ce8bd08198 100644
--- a/network/scapy/scapy.SlackBuild
+++ b/network/scapy/scapy.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for scapy (http://www.secdev.org/projects/scapy/)
#
-# Copyright 2008-2015 Corrado Franco (http://conraid.net)
+# Copyright 2008-2018 Corrado Franco (http://conraid.net)
# All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
@@ -23,8 +23,8 @@
# with this program (most likely, a file named COPYING). If not, see
# <http://www.gnu.org/licenses/>.
-PRGNAM=${PRGNAM:-scapy}
-VERSION=${VERSION:-2.3.1}
+PRGNAM=scapy
+VERSION=${VERSION:-2.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,7 +47,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
@@ -57,8 +57,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-sed -i "s%share/man/man1%man/man1%g" setup.py
+sed "s|share/man/man1|man/man1|g" -i setup.py
python setup.py build
python setup.py install --root=$PKG