summaryrefslogtreecommitdiffstats
path: root/network/scapy
diff options
context:
space:
mode:
Diffstat (limited to 'network/scapy')
-rw-r--r--network/scapy/scapy.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/network/scapy/scapy.SlackBuild b/network/scapy/scapy.SlackBuild
index 1c04fcbf8c..15c5867390 100644
--- a/network/scapy/scapy.SlackBuild
+++ b/network/scapy/scapy.SlackBuild
@@ -49,7 +49,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch setup.py for man path
sed -i "s%share/man/man1%man/man1%g" setup.py