summaryrefslogtreecommitdiffstats
path: root/network/speedtest-cli/speedtest-cli.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/speedtest-cli/speedtest-cli.SlackBuild')
-rw-r--r--network/speedtest-cli/speedtest-cli.SlackBuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/network/speedtest-cli/speedtest-cli.SlackBuild b/network/speedtest-cli/speedtest-cli.SlackBuild
index 9aa1ca2dcd..fc239bbd50 100644
--- a/network/speedtest-cli/speedtest-cli.SlackBuild
+++ b/network/speedtest-cli/speedtest-cli.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for speedtest-cli
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2021 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=speedtest-cli
-VERSION=${VERSION:-2.0.2}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.1.3}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true