summaryrefslogtreecommitdiffstats
path: root/network/surf/surf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/surf/surf.SlackBuild')
-rw-r--r--network/surf/surf.SlackBuild38
1 files changed, 16 insertions, 22 deletions
diff --git a/network/surf/surf.SlackBuild b/network/surf/surf.SlackBuild
index 872d1474aa..092649000c 100644
--- a/network/surf/surf.SlackBuild
+++ b/network/surf/surf.SlackBuild
@@ -2,10 +2,16 @@
# Slackware build script for surf
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230115 bkw: BUILD=2, strip library.
+# 20211020 bkw:
+# - updated for v2.1.
+# - rework patches again, can't build old versions no more.
+# - embiggen the default window size to 1280x1024.
+
# 20170625 bkw:
# - updated for v2.0 (webkit2gtk now required).
# - re-work searchengines.diff and homepage.diff for v2.0.
@@ -23,8 +29,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=surf
-VERSION=${VERSION:-2.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -36,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -71,17 +74,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Revert upstream commit f9714ab8, which requires gtk+3-3.20.0 or greater.
-# We only have 3.18.9 in Slack 14.2. NB: submission reviewer, please don't
-# move this patch into patches/ (it must always be applied, whether or not
-# PATCH=yes is set).
-patch -p1 < $CWD/getkbdevice.diff
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# Add a couple of nice patches from upstream, unless disabled. Note that
# upstream expects users to add patches and edit the source to customize it.
@@ -101,8 +95,8 @@ fi
TERMINAL=${TERMINAL:-rxvt}
# Default geometry
-WIDTH=${WIDTH:-800}
-HEIGHT=${HEIGHT:-600}
+WIDTH=${WIDTH:-1280}
+HEIGHT=${HEIGHT:-1024}
# Homepage (if browser called with no arguments). No effect if PATCH=no
HOMEPAGE="${HOMEPAGE:-https://duckduckgo.com/html/}"
@@ -118,11 +112,11 @@ fi
sed -i \
-e "s,@HOMEPAGE@,$HOMEPAGE,g" \
- -e "s,\<800\>,$WIDTH," \
- -e "s,\<600\>,$HEIGHT," \
$PRGNAM.c
sed -i \
+ -e "s,\<800\>,$WIDTH," \
+ -e "s,\<600\>,$HEIGHT," \
-e "s,\<st\>,$TERMINAL," \
-e "s,@SLACKVER@,$SLACKVER," \
config.def.h
@@ -135,7 +129,7 @@ sed -i \
config.mk
make
-strip $PRGNAM
+strip $PRGNAM *.so
make install DESTDIR=$PKG
gzip -9 $PKG/usr/man/man?/*.?