summaryrefslogtreecommitdiffstats
path: root/network/torsocks
diff options
context:
space:
mode:
Diffstat (limited to 'network/torsocks')
-rw-r--r--network/torsocks/doinst.sh2
-rw-r--r--network/torsocks/symbol_lookup.patch16
-rw-r--r--network/torsocks/torsocks.SlackBuild26
-rw-r--r--network/torsocks/torsocks.info8
4 files changed, 17 insertions, 35 deletions
diff --git a/network/torsocks/doinst.sh b/network/torsocks/doinst.sh
index 8dd043ac28..c5c111ed40 100644
--- a/network/torsocks/doinst.sh
+++ b/network/torsocks/doinst.sh
@@ -11,5 +11,5 @@ config() {
# Otherwise, we leave the .new copy for the admin to consider...
}
-config etc/torsocks.conf.new
+config etc/tor/torsocks.conf.new
diff --git a/network/torsocks/symbol_lookup.patch b/network/torsocks/symbol_lookup.patch
deleted file mode 100644
index ba8e62ec36..0000000000
--- a/network/torsocks/symbol_lookup.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/tsocks.c 2011-10-25 17:49:50.000000000 -0400
-+++ src/tsocks.c 2012-02-21 11:09:20.000000000 -0500
-@@ -175,9 +175,9 @@
- #define LOAD_ERROR(s,l) { \
- char *error; \
- error = dlerror(); \
-- show_msg(l, "The symbol %s() was not found in any shared " \
-- "library. The error reported was: %s!\n", s, \
-- (error)?error:"not found"); \
-+ if (error) \
-+ show_msg(l, "The symbol %s() was not found in any shared " \
-+ "library. The error reported was: %s!\n", s, error); \
- dlerror(); \
- }
- pthread_mutex_lock(&torsocks_init_mutex);
-
diff --git a/network/torsocks/torsocks.SlackBuild b/network/torsocks/torsocks.SlackBuild
index 3f34263f13..80a4b51462 100644
--- a/network/torsocks/torsocks.SlackBuild
+++ b/network/torsocks/torsocks.SlackBuild
@@ -5,8 +5,8 @@
# Written by Vincent Batts, vbatts@hashbangbash.com
PRGNAM=torsocks
-VERSION=${VERSION:-1.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.1.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -42,28 +42,28 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix a hardcoded lib path.
-sed -i -e 's|@prefix@/lib|@libdir@|' src/Makefile.in
-sed -i -e 's|@prefix@/lib|@libdir@|' src/torsocks.in
-patch -p0 < $CWD/symbol_lookup.patch
+sed -i -e 's|@prefix@/lib|@libdir@|' src/Makefile.am
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
+./autogen.sh
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
+ --enable-static=no \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
@@ -71,7 +71,7 @@ make
make install DESTDIR=$PKG
# do not clobber
-mv $PKG/etc/torsocks.conf{,.new}
+mv $PKG/etc/tor/torsocks.conf{,.new}
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -80,9 +80,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- INSTALL FAQ README* COPYING TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog INSTALL LICENSE README.md TODO gpl-2.0.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/network/torsocks/torsocks.info b/network/torsocks/torsocks.info
index e8cce8338e..50d0d6b0a0 100644
--- a/network/torsocks/torsocks.info
+++ b/network/torsocks/torsocks.info
@@ -1,8 +1,8 @@
PRGNAM="torsocks"
-VERSION="1.1"
-HOMEPAGE="http://torsocks.googlecode.com/"
-DOWNLOAD="http://torsocks.googlecode.com/files/torsocks-1.1.tar.gz"
-MD5SUM="1704fd009ed1a1c1dc9c6b72305a5449"
+VERSION="2.1.0"
+HOMEPAGE="https://gitweb.torproject.org/torsocks.git"
+DOWNLOAD="https://github.com/dgoulet/torsocks/archive/v2.1.0.tar.gz"
+MD5SUM="70e68c935071b92ac06b1e3faa9c59f8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""