summaryrefslogtreecommitdiffstats
path: root/network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild')
-rw-r--r--network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild21
1 files changed, 17 insertions, 4 deletions
diff --git a/network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild b/network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild
index 714e67f2c0..738a1af006 100644
--- a/network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild
+++ b/network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for transmission-remote-gtk
# Copyright 2012-2016 Chris Walker Copperas Cove, TX
-# Copyright 2020 B. Watson <urchlay@slackware.uk>
+# Copyright 2020-2023 B. Watson <urchlay@slackware.uk>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -32,6 +32,11 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230713 bkw: update for v1.6.0.
+# - new hard dep libsoup3.
+# - no more optional mrss dep (upstream dropped the RSS reader).
+
+# 20220623 bkw: update for v1.5.1.
# 20210926 bkw: BUILD=2, make NOTIFY=no also disable libappindicator.
# 20200526 bkw:
# - take over maintenance
@@ -47,7 +52,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=transmission-remote-gtk
-VERSION=${VERSION:-1.5.1}
+VERSION=${VERSION:-1.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -95,6 +100,14 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+# 20230713 bkw: mangle the meson.build so it works with Slackware
+# 15.0's meson-0.59.x. Eventually this will become difficult or
+# impossible, hopefully by then we have a new Slackware release with a
+# new enough meson.
+sed -i -e '/meson_version:/s,0.60.0,0.59.0,' \
+ -e "s/'ayatana-appindicator3-0.1', //" \
+ meson.build
+
[ "${NOTIFY:-yes}" = "no" ] && NOTIFYOPT="-Dlibappindicator=disabled"
mkdir build
@@ -118,8 +131,8 @@ cd ..
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
# 20200526 bkw: lots of optional deps, let the slack-desc keep track of them
-ldd $PKG/usr/bin/$PRGNAM > ldd.tmp
-for i in libappindicator libmrss GeoIP; do
+objdump -p $PKG/usr/bin/$PRGNAM | grep NEEDED > ldd.tmp
+for i in libappindicator GeoIP; do
opts+="$i:"
grep -q $i ldd.tmp && opts+="yes " || opts+="no "
done