summaryrefslogtreecommitdiffstats
path: root/network/transmission
diff options
context:
space:
mode:
Diffstat (limited to 'network/transmission')
-rw-r--r--network/transmission/README10
-rw-r--r--network/transmission/slack-desc6
-rw-r--r--network/transmission/transmission.SlackBuild38
-rw-r--r--network/transmission/transmission.info6
4 files changed, 31 insertions, 29 deletions
diff --git a/network/transmission/README b/network/transmission/README
index 41947e7d3a..cd84b5d14f 100644
--- a/network/transmission/README
+++ b/network/transmission/README
@@ -1,7 +1,5 @@
-Transmission is a lightweight open source BitTorrent client,
-providing useful functionality without feature bloat. It consists
-of a daemon, a GTK+ and a CLI client.
+Transmission is a lightweight open source BitTorrent client, providing
+useful functionality without feature bloat. It consists of a daemon, a
+GTK+, Qt and CLI client.
-Dependencies: libevent (available at SlackBuilds.org) is required,
- but transmission will use a built-in libevent if you don't have
- it installed already.
+This requires libevent.
diff --git a/network/transmission/slack-desc b/network/transmission/slack-desc
index 75c84331e9..fa608bbb4d 100644
--- a/network/transmission/slack-desc
+++ b/network/transmission/slack-desc
@@ -5,12 +5,12 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
transmission: Transmission (bittorrent client)
transmission:
transmission: Transmission is a lightweight open source BitTorrent client,
-transmission: providing useful functionality without feature bloat.
-transmission: It consists of a daemon, a GTK+ and a CLI client.
+transmission: providing useful functionality without feature bloat.
+transmission: It consists of a daemon, a GTK+, Qt and CLI client.
transmission:
transmission: Homepage: http://transmissionbt.com/
transmission:
diff --git a/network/transmission/transmission.SlackBuild b/network/transmission/transmission.SlackBuild
index c472472414..2fc1ccf939 100644
--- a/network/transmission/transmission.SlackBuild
+++ b/network/transmission/transmission.SlackBuild
@@ -2,8 +2,11 @@
# Slackware build script for transmission
# Written by Iskar Enev <iskar.enev[@]gmail.com>
+# As of version 2.22 maintained by Niels Horn <niels.horn@gmail.com>
+# Revision date: 2011/04/01
+
PRGNAM=transmission
-VERSION=2.03
+VERSION=${VERSION:-2.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -51,6 +54,9 @@ chmod -R a-s,u+w,go+r-w .
sed -i -e 's%-g -O3 -funroll-loops %%g' configure.ac
sed -i -e 's%-ggdb3 %%g' configure.ac
+# Fix hard-coded path of man file of Qt client
+sed -i "s|share/man/|man/|" qt/qtr.pro
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -64,28 +70,26 @@ CXXFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux \
--host=$ARCH-slackware-linux
+# build daemon, GTK and cli client
make
make install DESTDIR=$PKG
-# build the Qt client (qtr)
-( cd $TMP/$PRGNAM-$VERSION/qt
- qmake "QMAKE_CXXFLAGS+=$SLKCFLAGS" "QMAKE_CFLAGS+=$SLKCFLAGS" qtr.pro
+# build the Qt client (transmission-qt)
+cd $TMP/$PRGNAM-$VERSION/qt
+ qmake \
+ QMAKE_CXXFLAGS+="$SLKCFLAGS" \
+ QMAKE_CFLAGS+="$SLKCFLAGS" \
+ qtr.pro
sed -i -e 's% -g % %g' Makefile
make
INSTALL_ROOT=$PKG/usr make install
-)
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
-)
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+cd -
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCUMENTATION $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/network/transmission/transmission.info b/network/transmission/transmission.info
index c3cb667ab4..6a534e2ee4 100644
--- a/network/transmission/transmission.info
+++ b/network/transmission/transmission.info
@@ -1,8 +1,8 @@
PRGNAM="transmission"
-VERSION="2.03"
+VERSION="2.22"
HOMEPAGE="http://www.transmissionbt.com/"
-DOWNLOAD="http://download.m0k.org/transmission/files/transmission-2.03.tar.bz2"
-MD5SUM="7296c85673ed767a35de3883cb27b545"
+DOWNLOAD="http://download.transmissionbt.com/files/transmission-2.22.tar.bz2"
+MD5SUM="6499986bf769276310b00bda1090090d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Niels Horn"