summaryrefslogtreecommitdiffstats
path: root/network/twine/twine.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/twine/twine.SlackBuild')
-rw-r--r--network/twine/twine.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/network/twine/twine.SlackBuild b/network/twine/twine.SlackBuild
index 0284c8ea58..0cfbc94f61 100644
--- a/network/twine/twine.SlackBuild
+++ b/network/twine/twine.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for twine
-# Copyright 2016-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=twine
-VERSION=${VERSION:-1.11.0}
+VERSION=${VERSION:-3.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true