summaryrefslogtreecommitdiffstats
path: root/network/wireshark/wireshark.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/wireshark/wireshark.SlackBuild')
-rw-r--r--network/wireshark/wireshark.SlackBuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/network/wireshark/wireshark.SlackBuild b/network/wireshark/wireshark.SlackBuild
index 8bd0aa0578..07cc4c9ea2 100644
--- a/network/wireshark/wireshark.SlackBuild
+++ b/network/wireshark/wireshark.SlackBuild
@@ -26,7 +26,7 @@
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=wireshark
-VERSION=${VERSION:-1.2.0}
+VERSION=${VERSION:-1.2.6}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -56,7 +56,17 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Ammend hardcoded paths to /usr/lib/ which will give a problem when compiling on
+# systems with 32bit compat libs install. Thanks to Heinz Wiesinger.
+sed -i "s|/lib)|/lib$LIBDIRSUFFIX)|g" configure.in
+
+autoreconf -vif
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -67,10 +77,11 @@ CXXFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
- --with-ssl=/usr/lib \
+ --with-ssl=/usr/lib${LIBDIRSUFFIX} \
--enable-threads \
--disable-static \
--disable-debug \
+ --disable-usr-local \
--build=$ARCH-slackware-linux
make
@@ -108,4 +119,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}