summaryrefslogtreecommitdiffstats
path: root/network/wvdial
diff options
context:
space:
mode:
Diffstat (limited to 'network/wvdial')
-rw-r--r--network/wvdial/Makefile.diff29
-rw-r--r--network/wvdial/README5
-rw-r--r--network/wvdial/doinst.sh17
-rw-r--r--network/wvdial/slack-desc19
-rw-r--r--network/wvdial/wvdial.SlackBuild72
-rw-r--r--network/wvdial/wvdial.conf21
-rw-r--r--network/wvdial/wvdial.info8
7 files changed, 171 insertions, 0 deletions
diff --git a/network/wvdial/Makefile.diff b/network/wvdial/Makefile.diff
new file mode 100644
index 0000000000..95f7b4a98f
--- /dev/null
+++ b/network/wvdial/Makefile.diff
@@ -0,0 +1,29 @@
+--- Makefile.ORIG 2008-05-10 22:59:21.000000000 -0500
++++ Makefile 2008-05-10 23:01:31.000000000 -0500
+@@ -35,17 +36,17 @@
+ wvdial wvdialconf papchaptest pppmon: wvdial.a
+
+ install-bin: all
+- [ -d ${BINDIR} ] || install -d ${BINDIR}
+- [ -d ${PPPDIR} ] || install -d ${PPPDIR}
+- install -m 0755 wvdial wvdialconf ${BINDIR}
+- cp ppp.provider ${PPPDIR}/wvdial
+- cp ppp.provider-pipe ${PPPDIR}/wvdial-pipe
++ [ -d $(DESTDIR)/${BINDIR} ] || install -d $(DESTDIR)/${BINDIR}
++ [ -d $(DESTDIR)/${PPPDIR} ] || install -d $(DESTDIR)/${PPPDIR}
++ install -m 0755 wvdial wvdialconf $(DESTDIR)/${BINDIR}
++ cp ppp.provider $(DESTDIR)/${PPPDIR}/wvdial
++ cp ppp.provider-pipe $(DESTDIR)/${PPPDIR}/wvdial-pipe
+
+ install-man:
+- [ -d ${MANDIR}/man1 ] || install -d ${MANDIR}/man1
+- [ -d ${MANDIR}/man5 ] || install -d ${MANDIR}/man5
+- install -m 0644 wvdial.1 wvdialconf.1 ${MANDIR}/man1
+- install -m 0644 wvdial.conf.5 ${MANDIR}/man5
++ [ -d $(DESTDIR)/${MANDIR}/man1 ] || install -d $(DESTDIR)/${MANDIR}/man1
++ [ -d $(DESTDIR)/${MANDIR}/man5 ] || install -d $(DESTDIR)/${MANDIR}/man5
++ install -m 0644 wvdial.1 wvdialconf.1 $(DESTDIR)/${MANDIR}/man1
++ install -m 0644 wvdial.conf.5 $(DESTDIR)/${MANDIR}/man5
+
+ install: install-bin install-man
+
diff --git a/network/wvdial/README b/network/wvdial/README
new file mode 100644
index 0000000000..a4fe8c76a1
--- /dev/null
+++ b/network/wvdial/README
@@ -0,0 +1,5 @@
+WvDial is a program that makes it easy to connect your Linux workstation
+to the Internet. It will automatically detect your modem, and it can log
+into almost any Internet provider's server without any special configuration.
+
+This requires wvstreams (which is also available from SlackBuilds.org).
diff --git a/network/wvdial/doinst.sh b/network/wvdial/doinst.sh
new file mode 100644
index 0000000000..2a50656fa9
--- /dev/null
+++ b/network/wvdial/doinst.sh
@@ -0,0 +1,17 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/wvdial.conf.new
+config etc/ppp/peers/wvdial-pipe.new
+config etc/ppp/peers/wvdial.new
+
diff --git a/network/wvdial/slack-desc b/network/wvdial/slack-desc
new file mode 100644
index 0000000000..4a50855925
--- /dev/null
+++ b/network/wvdial/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+wvdial: wvdial (ppp dialer app)
+wvdial:
+wvdial: wvdial is a program that makes it easy to connect your Linux
+wvdial: workstation to the Internet. It will automatically detect your
+wvdial: modem, and it can log into almost any Internet provider's
+wvdial: server without any special configuration.
+wvdial:
+wvdial: http://alumnit.ca/wiki/index.php?page=WvDial
+wvdial:
+wvdial:
+wvdial:
diff --git a/network/wvdial/wvdial.SlackBuild b/network/wvdial/wvdial.SlackBuild
new file mode 100644
index 0000000000..28c60043d6
--- /dev/null
+++ b/network/wvdial/wvdial.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for wvdial
+
+# Written by Vincent Batts, vbatts@batts.mine.nu
+
+PRGNAM=wvdial
+VERSION=1.60
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Add DESTDIR support to the Makefile
+patch -u Makefile $CWD/Makefile.diff
+
+make prefix=/usr MANDIR=/usr/man
+make prefix=/usr MANDIR=/usr/man install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || exit 1
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+# Add a sample config file, and don't clobber any of them on upgrades
+cat $CWD/wvdial.conf > $PKG/etc/wvdial.conf.new
+mv $PKG/etc/ppp/peers/wvdial-pipe $PKG/etc/ppp/peers/wvdial-pipe.new
+mv $PKG/etc/ppp/peers/wvdial $PKG/etc/ppp/peers/wvdial.new
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES COPYING.LIB ChangeLog FAQ README TODO MENUS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/wvdial/wvdial.conf b/network/wvdial/wvdial.conf
new file mode 100644
index 0000000000..d3ce8421b2
--- /dev/null
+++ b/network/wvdial/wvdial.conf
@@ -0,0 +1,21 @@
+
+[Dialer Defaults]
+Modem = /dev/modem
+Baud = 57600
+Init1 = ATZ
+Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
+Init3 =
+Area Code =
+Phone = 0
+Username =
+Password =
+Ask Password = 0
+Dial Command = ATDT
+Stupid Mode = 1
+Compuserve = 0
+Force Address =
+Idle Seconds = 300
+DialMessage1 =
+DialMessage2 =
+ISDN = 0
+Auto DNS = 1
diff --git a/network/wvdial/wvdial.info b/network/wvdial/wvdial.info
new file mode 100644
index 0000000000..357ce5fa02
--- /dev/null
+++ b/network/wvdial/wvdial.info
@@ -0,0 +1,8 @@
+PRGNAM="wvdial"
+VERSION="1.60"
+HOMEPAGE="http://alumnit.ca/wiki/index.php?page=WvDial"
+DOWNLOAD="http://alumnit.ca/download/wvdial-1.60.tar.gz"
+MD5SUM="27fbbde89f8fd9f6e735a8efa5217fc9"
+MAINTAINER="Vincent Batts"
+EMAIL="vbatts@batts.mine.nu"
+APPROVED="rworkman"