summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
Diffstat (limited to 'network')
-rw-r--r--network/transmission/doinst.sh12
-rw-r--r--network/transmission/slack-desc2
-rw-r--r--network/transmission/transmission.SlackBuild26
-rw-r--r--network/transmission/transmission.info8
4 files changed, 37 insertions, 11 deletions
diff --git a/network/transmission/doinst.sh b/network/transmission/doinst.sh
index 0039459a06..69d003d68b 100644
--- a/network/transmission/doinst.sh
+++ b/network/transmission/doinst.sh
@@ -1,3 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications
+fi
+
if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
fi
diff --git a/network/transmission/slack-desc b/network/transmission/slack-desc
index df14432368..75c84331e9 100644
--- a/network/transmission/slack-desc
+++ b/network/transmission/slack-desc
@@ -12,7 +12,7 @@ transmission: Transmission is a lightweight open source BitTorrent client,
transmission: providing useful functionality without feature bloat.
transmission: It consists of a daemon, a GTK+ and a CLI client.
transmission:
-transmission: http://transmissionbt.com/
+transmission: Homepage: http://transmissionbt.com/
transmission:
transmission:
transmission:
diff --git a/network/transmission/transmission.SlackBuild b/network/transmission/transmission.SlackBuild
index ff34c1745a..386b705f9d 100644
--- a/network/transmission/transmission.SlackBuild
+++ b/network/transmission/transmission.SlackBuild
@@ -1,11 +1,9 @@
#!/bin/sh
-
# Slackware build script for transmission
-
# Written by Iskar Enev <iskar.enev[@]gmail.com>
PRGNAM=transmission
-VERSION=1.52
+VERSION=1.82
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -19,13 +17,16 @@ DOCUMENTATION="AUTHORS COPYING INSTALL NEWS README"
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -40,11 +41,15 @@ find . \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+
+sed -i -e 's%-g -O3 -funroll-loops %%g' configure.ac
+sed -i -e 's%-ggdb3 %%g' configure.ac
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
@@ -56,11 +61,19 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
+# build the Qt client (qtr)
+( cd $TMP/$PRGNAM-$VERSION/qt
+ qmake "QMAKE_CXXFLAGS+=$SLKCFLAGS" "QMAKE_CFLAGS+=$SLKCFLAGS" qtr.pro
+ sed -i -e 's% -g % %g' Makefile
+ make
+ INSTALL_ROOT=$PKG/usr make install
+)
+
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
+ xargs strip --strip-unneeded 2> /dev/null || true
)
( cd $PKG/usr/man
@@ -77,4 +90,5 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/network/transmission/transmission.info b/network/transmission/transmission.info
index a6817d0c1e..9f202a41b8 100644
--- a/network/transmission/transmission.info
+++ b/network/transmission/transmission.info
@@ -1,8 +1,10 @@
PRGNAM="transmission"
-VERSION="1.52"
+VERSION="1.82"
HOMEPAGE="http://www.transmissionbt.com/"
-DOWNLOAD="http://download.m0k.org/transmission/files/transmission-1.52.tar.bz2"
-MD5SUM="2a1a628c2a8872934575cb4351bca291"
+DOWNLOAD="http://download.m0k.org/transmission/files/transmission-1.82.tar.bz2"
+MD5SUM="00fe9cc2c4f8e004c89825812e387fc4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
MAINTAINER="Iskar Enev"
EMAIL="<iskar.enev[@]gmail.com>"
APPROVED="dsomero"