summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
Diffstat (limited to 'network')
-rw-r--r--network/transmission/transmission.SlackBuild21
-rw-r--r--network/transmission/transmission.info8
2 files changed, 14 insertions, 15 deletions
diff --git a/network/transmission/transmission.SlackBuild b/network/transmission/transmission.SlackBuild
index 6a41187245..b1bae6b467 100644
--- a/network/transmission/transmission.SlackBuild
+++ b/network/transmission/transmission.SlackBuild
@@ -3,16 +3,15 @@
# Written by Iskar Enev <iskar.enev[@]gmail.com>
PRGNAM=transmission
-VERSION=1.92
+VERSION=2.03
+ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -48,12 +47,8 @@ mkdir -p $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
+chmod -R a-s,u+w,go+r-w .
+
sed -i -e 's%-g -O3 -funroll-loops %%g' configure.ac
sed -i -e 's%-ggdb3 %%g' configure.ac
@@ -81,8 +76,12 @@ make install DESTDIR=$PKG
INSTALL_ROOT=$PKG/usr make install
)
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
diff --git a/network/transmission/transmission.info b/network/transmission/transmission.info
index a66702c8be..e8fa3e30e8 100644
--- a/network/transmission/transmission.info
+++ b/network/transmission/transmission.info
@@ -1,10 +1,10 @@
PRGNAM="transmission"
-VERSION="1.92"
+VERSION="2.03"
HOMEPAGE="http://www.transmissionbt.com/"
-DOWNLOAD="http://download.m0k.org/transmission/files/transmission-1.92.tar.bz2"
-MD5SUM="561357621331f294c87f78e22783a283"
+DOWNLOAD="http://download.m0k.org/transmission/files/transmission-2.03.tar.bz2"
+MD5SUM="7296c85673ed767a35de3883cb27b545"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Iskar Enev"
EMAIL="<iskar.enev[@]gmail.com>"
-APPROVED="Erik Hanson"
+APPROVED="Michiel"