summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
Diffstat (limited to 'network')
-rw-r--r--network/bmon/bmon.SlackBuild21
-rw-r--r--network/bmon/bmon.info10
-rw-r--r--network/bmon/disable_libnl.diff30
-rw-r--r--network/bmon/dumb_compile_error_fixes.diff24
-rw-r--r--network/bmon/slack-desc22
5 files changed, 92 insertions, 15 deletions
diff --git a/network/bmon/bmon.SlackBuild b/network/bmon/bmon.SlackBuild
index b6fc3623a6..6607b7135a 100644
--- a/network/bmon/bmon.SlackBuild
+++ b/network/bmon/bmon.SlackBuild
@@ -5,7 +5,7 @@
# Written by B. Watson (yalhcru at gmail dot com)
PRGNAM=bmon
-VERSION=${VERSION:-2.0.1}
+VERSION=${VERSION:-2.1.0}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -38,23 +38,36 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# bmon is by the author of libnl, but apparently bmon only works with
+# 0.x versions of libnl (specifically, it won't build with the libnl 1.1
+# that's included in Slackware 13). There's no --disable-libnl or similar
+# option to the configure script, so we have to patch it.
+patch -p1 < $CWD/disable_libnl.diff
+
+# missing = signs... sigh.
+patch -p1 < $CWD/dumb_compile_error_fixes.diff
+
+autoreconf
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --mandir=/usr/man
+ --mandir=/usr/man \
+ --build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
strip $PKG/usr/bin/$PRGNAM
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
-cp BUGS TODO ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a BUGS TODO ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
+chmod 0644 $PKG/usr/doc/$PRGNAM-$VERSION/*
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/bmon/bmon.info b/network/bmon/bmon.info
index a3c6d7eff1..766a383a76 100644
--- a/network/bmon/bmon.info
+++ b/network/bmon/bmon.info
@@ -1,8 +1,10 @@
PRGNAM="bmon"
-VERSION="2.0.1"
+VERSION="2.1.0"
HOMEPAGE="http://people.suug.ch/~tgr/bmon/"
-DOWNLOAD="http://people.suug.ch/~tgr/bmon/files/bmon-2.0.1.tar.gz"
-MD5SUM="d0da9d05f18c82a621171985d536dec7"
+DOWNLOAD="ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/bmon-2.1.0.tar.gz"
+MD5SUM="3111a027907016c0902d67350c619df6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"
-APPROVED="David Somero" \ No newline at end of file
+APPROVED="rworkman"
diff --git a/network/bmon/disable_libnl.diff b/network/bmon/disable_libnl.diff
new file mode 100644
index 0000000000..1f5126e907
--- /dev/null
+++ b/network/bmon/disable_libnl.diff
@@ -0,0 +1,30 @@
+diff -Naur bmon-2.1.0/configure.ac bmon-2.1.0.patched/configure.ac
+--- bmon-2.1.0/configure.ac 2005-04-05 11:01:33.000000000 -0400
++++ bmon-2.1.0.patched/configure.ac 2009-09-30 23:43:25.000000000 -0400
+@@ -188,26 +188,6 @@
+
+ #####################################################################
+ ##
+-## libnl check
+-##
+-#####################################################################
+-NL="No "
+-AC_CHECK_LIB(nl, nl_connect, [
+- AC_DEFINE_UNQUOTED(HAVE_NL, "1", [have libnl])
+- LIBNL="-lnl"
+- NL="Yes"
+-],[
+- case ${target_os} in
+- *linux*)
+- echo
+- echo "*** Warning: Building bmon on Linuxx w/o libnl ***"
+- echo
+- ;;
+- esac
+-])
+-
+-#####################################################################
+-##
+ ## libm check
+ ##
+ #####################################################################
diff --git a/network/bmon/dumb_compile_error_fixes.diff b/network/bmon/dumb_compile_error_fixes.diff
new file mode 100644
index 0000000000..67f698ee07
--- /dev/null
+++ b/network/bmon/dumb_compile_error_fixes.diff
@@ -0,0 +1,24 @@
+diff -Naur bmon-2.1.0.old/src/out_audio.c bmon-2.1.0.patched/src/out_audio.c
+--- bmon-2.1.0.old/src/out_audio.c 2005-04-05 11:01:33.000000000 -0400
++++ bmon-2.1.0.patched/src/out_audio.c 2009-09-30 23:48:28.000000000 -0400
+@@ -141,7 +141,7 @@
+ .om_draw = audio_draw,
+ .om_set_opts = audio_set_opts,
+ .om_probe = audio_probe,
+- .om_shutdown audio_shutdown,
++ .om_shutdown = audio_shutdown,
+ };
+
+ static void __init audio_init(void)
+diff -Naur bmon-2.1.0.old/src/out_xml_event.c bmon-2.1.0.patched/src/out_xml_event.c
+--- bmon-2.1.0.old/src/out_xml_event.c 2005-04-05 11:01:33.000000000 -0400
++++ bmon-2.1.0.patched/src/out_xml_event.c 2009-09-30 23:46:22.000000000 -0400
+@@ -127,7 +127,7 @@
+ .om_draw = xml_event_draw,
+ .om_set_opts = xml_event_set_opts,
+ .om_probe = xml_event_probe,
+- .om_shutdown xml_event_shutdown,
++ .om_shutdown = xml_event_shutdown,
+ };
+
+ static void __init xml_event_init(void)
diff --git a/network/bmon/slack-desc b/network/bmon/slack-desc
index 1e3e57676a..6d178a6d19 100644
--- a/network/bmon/slack-desc
+++ b/network/bmon/slack-desc
@@ -1,11 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
bmon: bmon (portable bandwidth monitor and rate estimator)
-bmon: bmon is a portable bandwidth monitor and rate estimator running on
-bmon: various operating systems. It supports various input methods for different
-bmon: architectures. Various output modes exist including an interactive curses
-bmon: interface, lightweight HTML output but also formatable ASCII output.
bmon:
-bmon: Statistics may be distributed over a network using multicast or unicast
-bmon: and collected at some point to generate a summary of statistics for a
-bmon: set of nodes.
+bmon: bmon is a portable bandwidth monitor and rate estimator It supports
+bmon: various input methods for different architectures. Various output
+bmon: modes exist including an interactive curses interface, lightweight
+bmon: HTML output but also formatable ASCII output. Statistics may be
+bmon: distributed over a network using multicast or unicast and collected
+bmon: at some point to generate a summary of statistics for a set of nodes.
bmon:
bmon: Homepage: http://people.suug.ch/~tgr/bmon/
+bmon: