summaryrefslogtreecommitdiffstats
path: root/office/LibreOffice/LibreOffice.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/LibreOffice/LibreOffice.SlackBuild')
-rw-r--r--office/LibreOffice/LibreOffice.SlackBuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/office/LibreOffice/LibreOffice.SlackBuild b/office/LibreOffice/LibreOffice.SlackBuild
index 6ce5c43442..14fd0f2042 100644
--- a/office/LibreOffice/LibreOffice.SlackBuild
+++ b/office/LibreOffice/LibreOffice.SlackBuild
@@ -26,7 +26,7 @@
PRGNAM=LibreOffice
SRCNAM=libreoffice
-VERSION=${VERSION:-6.2.4.2}
+VERSION=${VERSION:-6.2.8.2}
SHORT_VERSION=${VERSION%.*.*}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -91,9 +91,9 @@ jval="$(echo $MAKEFLAGS |grep -o "\-j *[0-9]*" | grep -o "[0-9]*")" || true
# If PARALLEL environment variable is set, use that to override everything.
[ "${PARALLEL:-0}" != "0" ] && parallel="--with-parallelism=$PARALLEL"
-JAVA=${JAVA:-openjdk}
-if [ "$JAVA" = "openjdk" ]; then
- . /etc/profile.d/openjdk.sh
+JAVA=${JAVA:-openjdk7}
+if [ "$JAVA" = "openjdk7" ]; then
+ . /etc/profile.d/openjdk7.sh
use_java="--with-java=java"
elif [ "$JAVA" = "openjdk8" ]; then
. /etc/profile.d/openjdk8.sh
@@ -136,7 +136,13 @@ if pkg-config --exists mdds-1.4 ; then mdds="--with-system-mdds" ; else mdds=""
if pkg-config --exists mythes ; then mythes="--with-system-mythes" ; else mythes="" ; fi
if test -x /usr/bin/odbc_config ; then odbc="--with-system-odbc" ; else odbc="" ; fi
#if test -d /usr/lib${LIBDIRSUFFIX}/python3*/site-packages/lxml ; then lxml="--with-system-lxml" ; else lxml="" ; fi
-if pkg-config --exists xmlsec1 ; then xmlsec="--with-system-xmlsec" ; else xmlsec="" ; fi
+if pkg-config --exists xmlsec1 ; then
+ xmlsec="--with-system-xmlsec"
+else
+ xmlsec=""
+ # Also ensure correct nspr implementation is used if building libreoffice supplied xmlsec
+ sed -i -e 's:openssl:openssl --with-mozilla-ver=/usr:' external/xmlsec/ExternalProject_xmlsec.mk
+fi
#if test -e /usr/share/ant/lib/rhino.jar ; then rhino="--with-system-rhino --with-rhino-jar=/usr/share/ant/lib/rhino.jar" ; else rhino="" ; fi
if pkg-config --exists libvlc ; then vlc="--enable-vlc" ; else vlc="" ; fi
# Building with vlc backend is marked as experimental so demand explicit indication via environment variable VLC to do it.