summaryrefslogtreecommitdiffstats
path: root/office/LibreOffice/LibreOffice.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/LibreOffice/LibreOffice.SlackBuild')
-rw-r--r--office/LibreOffice/LibreOffice.SlackBuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/office/LibreOffice/LibreOffice.SlackBuild b/office/LibreOffice/LibreOffice.SlackBuild
index f02b184f47..14fd0f2042 100644
--- a/office/LibreOffice/LibreOffice.SlackBuild
+++ b/office/LibreOffice/LibreOffice.SlackBuild
@@ -26,7 +26,7 @@
PRGNAM=LibreOffice
SRCNAM=libreoffice
-VERSION=${VERSION:-6.1.4.2}
+VERSION=${VERSION:-6.2.8.2}
SHORT_VERSION=${VERSION%.*.*}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,10 +70,6 @@ rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
cd $SRCNAM-$VERSION
-# Required for updates to mdds, liborcus (needs autogen.sh)
-patch -p1 < $CWD/0001-Update-mdds-to-1.4.1.patch
-patch -p1 < $CWD/0001-Update-orcus-to-0.14.0.patch
-
if [ "$HAVE_SRCS_TARBALL" = "1" ]; then
tar xvf $CWD/$SRCNAM-${VERSION}-srcs.tar.xz
fi
@@ -95,9 +91,9 @@ jval="$(echo $MAKEFLAGS |grep -o "\-j *[0-9]*" | grep -o "[0-9]*")" || true
# If PARALLEL environment variable is set, use that to override everything.
[ "${PARALLEL:-0}" != "0" ] && parallel="--with-parallelism=$PARALLEL"
-JAVA=${JAVA:-openjdk}
-if [ "$JAVA" = "openjdk" ]; then
- . /etc/profile.d/openjdk.sh
+JAVA=${JAVA:-openjdk7}
+if [ "$JAVA" = "openjdk7" ]; then
+ . /etc/profile.d/openjdk7.sh
use_java="--with-java=java"
elif [ "$JAVA" = "openjdk8" ]; then
. /etc/profile.d/openjdk8.sh
@@ -137,11 +133,16 @@ if pkg-config --exists libpq ; then postgresql="--with-system-postgresql" ; else
if pkg-config --exists libucpp ; then ucpp="--with-system-ucpp" ; else ucpp="" ; fi
if test -e /usr/include/lpsolve ; then lpsolve="--with-system-lpsolve" ; else lpsolve="" ; fi
if pkg-config --exists mdds-1.4 ; then mdds="--with-system-mdds" ; else mdds="" ; fi
-if test -e /usr/include/mysql_connection.h ; then mysql="--with-system-mysql-cppconn" ; else mysql="" ; fi
if pkg-config --exists mythes ; then mythes="--with-system-mythes" ; else mythes="" ; fi
if test -x /usr/bin/odbc_config ; then odbc="--with-system-odbc" ; else odbc="" ; fi
#if test -d /usr/lib${LIBDIRSUFFIX}/python3*/site-packages/lxml ; then lxml="--with-system-lxml" ; else lxml="" ; fi
-if pkg-config --exists xmlsec1 ; then xmlsec="--with-system-xmlsec" ; else xmlsec="" ; fi
+if pkg-config --exists xmlsec1 ; then
+ xmlsec="--with-system-xmlsec"
+else
+ xmlsec=""
+ # Also ensure correct nspr implementation is used if building libreoffice supplied xmlsec
+ sed -i -e 's:openssl:openssl --with-mozilla-ver=/usr:' external/xmlsec/ExternalProject_xmlsec.mk
+fi
#if test -e /usr/share/ant/lib/rhino.jar ; then rhino="--with-system-rhino --with-rhino-jar=/usr/share/ant/lib/rhino.jar" ; else rhino="" ; fi
if pkg-config --exists libvlc ; then vlc="--enable-vlc" ; else vlc="" ; fi
# Building with vlc backend is marked as experimental so demand explicit indication via environment variable VLC to do it.
@@ -163,7 +164,6 @@ extlanguagetool="--enable-ext-languagetool"; [ "${EXTLANGUAGETOOL:-no}" != "yes"
extwikipub="--enable-ext-wiki-publisher"; [ "${EXTWIKIPUB:-no}" != "yes" ] && extwikipub=""
extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] && extnlpsolver=""
-extmariadb="--enable-ext-mariadb-connector"; [ "${EXTMARIADB:-yes}" != "yes" ] && extmariadb=""
./autogen.sh \
CFLAGS="$SLKCFLAGS" \
@@ -179,13 +179,11 @@ extmariadb="--enable-ext-mariadb-connector"; [ "${EXTMARIADB:-yes}" != "yes" ]
--with-vendor="Just Another Slacker" \
--with-lang="$LOLANGS" \
--enable-release-build=yes \
- --enable-ext-mariadb-connector \
--enable-gio \
$extct2n \
$extnumbertext \
$extnlpsolver \
$extlanguagetool \
- $extmariadb \
$extwikipub \
$avahi \
$Python3 \
@@ -194,7 +192,6 @@ extmariadb="--enable-ext-mariadb-connector"; [ "${EXTMARIADB:-yes}" != "yes" ]
$use_ccache \
$use_java \
$parallel \
- --with-alloc=system \
--with-tls="nss" \
--with-x \
--without-krb5 \
@@ -261,7 +258,6 @@ extmariadb="--enable-ext-mariadb-connector"; [ "${EXTMARIADB:-yes}" != "yes" ]
$valgrind \
$ucpp \
$odbc \
- $mysql \
$xmlsec \