summaryrefslogtreecommitdiffstats
path: root/office/antiword
diff options
context:
space:
mode:
Diffstat (limited to 'office/antiword')
-rw-r--r--office/antiword/README4
-rw-r--r--office/antiword/antiword.SlackBuild43
-rw-r--r--office/antiword/antiword.info4
-rw-r--r--office/antiword/patch.Makefile11
-rw-r--r--office/antiword/slack-desc13
5 files changed, 35 insertions, 40 deletions
diff --git a/office/antiword/README b/office/antiword/README
index e9c4992040..a5f7ae617c 100644
--- a/office/antiword/README
+++ b/office/antiword/README
@@ -3,7 +3,3 @@ antiword converts the binary files from Word 2, 6, 7, 97, 2000,
2002 and 2003 to plain text and to PostScript TM .
The homepage of antiword is found at http://www.winfield.demon.nl/
-
-antiword does not seem to depend on other packages.
-No incompatibilites are known so far. No special configuration
-is needed after installing the package.
diff --git a/office/antiword/antiword.SlackBuild b/office/antiword/antiword.SlackBuild
index d7de2d8d21..4179473007 100644
--- a/office/antiword/antiword.SlackBuild
+++ b/office/antiword/antiword.SlackBuild
@@ -1,6 +1,8 @@
#!/bin/sh
+
# Slackware build script for antiword
-# Copyright 2007 by titopoquito (titopoquito@cooltoad.com)
+
+# Copyright 2007-2009 by titopoquito (titopoquito@gmail.com)
# Permission to use, copy, modify, and distribute this software for
# any purpose with or without fee is hereby granted, provided that
# the above copyright notice and this permission notice appear in all
@@ -18,17 +20,15 @@
# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
# SUCH DAMAGE.
-# ---------------------------------------------------------------------------
-# Modified by the SlackBuilds.org Project
-# Exit on most errors
-set -e
+# Modified by the SlackBuilds.org Project
PRGNAM=antiword
VERSION=0.37
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -36,36 +36,45 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# let antiword be installed to /usr instead of /usr/local
-# since there is no configure utility here, we'll patch the Makefile
-patch -p0 < $CWD/patch.Makefile
-
-# call "make all" instead the usual "make" and "make global_install"
-# instead of "make install" to make the binary accessable by all users
-make all
-make global_install DESTDIR=$PKG
+make \
+ all \
+ OPT="$SLKCFLAGS" \
+ GLOBAL_INSTALL_DIR=/usr/bin
+make \
+ global_install \
+ GLOBAL_INSTALL_DIR=/usr/bin \
+ DESTDIR=$PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
# The man page is NOT installed correctly. Copy it manually ...
mkdir -p $PKG/usr/man/man1
-gzip -9cf Docs/antiword.1 > $PKG/usr/man/man1/antiword.1.gz
+gzip -9c Docs/antiword.1 > $PKG/usr/man/man1/antiword.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a Docs/* $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/office/antiword/antiword.info b/office/antiword/antiword.info
index cade87b62d..f3a522132e 100644
--- a/office/antiword/antiword.info
+++ b/office/antiword/antiword.info
@@ -4,5 +4,5 @@ HOMEPAGE="http://www.winfield.demon.nl/"
DOWNLOAD="http://www.winfield.demon.nl/linux/antiword-0.37.tar.gz"
MD5SUM="f868e2a269edcbc06bf77e89a55898d1"
MAINTAINER="titopoquito"
-EMAIL="titopoquito@cooltoad.com"
-APPROVED="alien"
+EMAIL="titopoquito@gmail.com"
+APPROVED="rworkman"
diff --git a/office/antiword/patch.Makefile b/office/antiword/patch.Makefile
deleted file mode 100644
index ed3e5b4cce..0000000000
--- a/office/antiword/patch.Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- /usr/packages/slackbuild/recoll-Dateisuche/01_antiword/antiword-0.37/Makefile 2005-10-29 19:13:15.000000000 +0200
-+++ Makefile 2007-04-05 21:44:19.000000000 +0200
-@@ -36,7 +36,7 @@
- LOCAL_INSTALL_DIR = $(HOME)/bin
- LOCAL_RESOURCES_DIR = $(HOME)/.antiword
-
--GLOBAL_INSTALL_DIR = /usr/local/bin
-+GLOBAL_INSTALL_DIR = /usr/bin
- GLOBAL_RESOURCES_DIR = /usr/share/antiword
-
- all: $(PROGS)
diff --git a/office/antiword/slack-desc b/office/antiword/slack-desc
index 607408f9f9..3fb8f81b82 100644
--- a/office/antiword/slack-desc
+++ b/office/antiword/slack-desc
@@ -4,15 +4,16 @@
# the right side marks the last column you can put a character in. You must make
# exactly 11 lines for the formatting to be correct. It's also customary to
# leave one space after the ':'.
+
|-----handy-ruler------------------------------------------------------|
antiword: antiword (a free MS Word reader)
-antiword:
+antiword:
antiword: Antiword is a free MS Word reader for Linux and RISC OS.
antiword: Antiword converts the binary files from Word 2, 6, 7, 97, 2000,
antiword: 2002 and 2003 to plain text and to PostScript TM .
-antiword:
-antiword:
-antiword:
-antiword:
+antiword:
antiword: http://www.winfield.demon.nl/
-antiword:
+antiword:
+antiword:
+antiword:
+antiword: