summaryrefslogtreecommitdiffstats
path: root/office/elyxer/elyxer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/elyxer/elyxer.SlackBuild')
-rw-r--r--office/elyxer/elyxer.SlackBuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/office/elyxer/elyxer.SlackBuild b/office/elyxer/elyxer.SlackBuild
index 2b792092f8..8f28f2c7e2 100644
--- a/office/elyxer/elyxer.SlackBuild
+++ b/office/elyxer/elyxer.SlackBuild
@@ -9,12 +9,10 @@ VERSION=${VERSION:-1.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -58,13 +56,14 @@ python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mkdir -p $PKG/usr/bin
+cat $CWD/elyxer.sh > $PKG/usr/bin/elyxer
+chmod 0755 $PKG/usr/bin/elyxer
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README gpl-3.0-standalone.html docs $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-mkdir -p $PKG/usr/bin
-cat $CWD/elyxer.sh > $PKG/usr/bin/elyxer && chmod 0755 $PKG/usr/bin/elyxer
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc