summaryrefslogtreecommitdiffstats
path: root/office/x_x/x_x.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/x_x/x_x.SlackBuild')
-rw-r--r--office/x_x/x_x.SlackBuild36
1 files changed, 9 insertions, 27 deletions
diff --git a/office/x_x/x_x.SlackBuild b/office/x_x/x_x.SlackBuild
index c39f330656..929eaf0c57 100644
--- a/office/x_x/x_x.SlackBuild
+++ b/office/x_x/x_x.SlackBuild
@@ -2,15 +2,21 @@
# Slackware build script for x_x
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20231005 bkw: BUILD=2, force use of python 3. apparently my previous
+# comment was wrong: this does run under python 3. and it now has to,
+# because click no longer supports python 2.
+
+# 20210929 bkw: force use of python 2. this doesn't run under 3.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=x_x
VERSION=${VERSION:-20150330_d236f8f}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +28,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -34,20 +37,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -60,14 +49,7 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# 20201115 bkw: at some point, Slackware's /usr/bin/python will be python3.
-# This stuff can go away then.
-case "${PYVER:-auto}" in
- 2|3) ;; # use as-is
- auto) PYVER=2; python3 -c 'import sys' 2>/dev/null && PYVER=3 ;;
-esac
-
-python$PYVER setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
# man page manually converted from README.rst by SlackBuild author.
mkdir -p $PKG/usr/man/man1