summaryrefslogtreecommitdiffstats
path: root/office/zathura/zathura.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/zathura/zathura.SlackBuild')
-rw-r--r--office/zathura/zathura.SlackBuild21
1 files changed, 20 insertions, 1 deletions
diff --git a/office/zathura/zathura.SlackBuild b/office/zathura/zathura.SlackBuild
index 74a164ec78..b5cbf77734 100644
--- a/office/zathura/zathura.SlackBuild
+++ b/office/zathura/zathura.SlackBuild
@@ -22,6 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20170711 bkw:
+# - BUILD=2
+# - Include API docs in package
+# - Switch to github URLs since upstream's site has been broken for 3-4
+# days now. Side effect is, it makes it easier for my update script to
+# let me know when there's a new release. This means adding the built
+# man pages to SBo git (otherwise I'd have Sphinx as a dep, yuck).
+
# 20170125 bkw:
# - Updated for v0.3.7, poppler plugin v0.2.7
@@ -53,7 +61,7 @@
PRGNAM=zathura
VERSION=${VERSION:-0.3.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -135,6 +143,10 @@ patch -p1 < $CWD/dlopen_hack.diff
sed -i "s/-pedantic/$SLKCFLAGS/" config.mk
sed -i '/-fdiagnostics-color/d' colors.mk
+# 20170711 bkw: git tarballs don't include prebuilt man pages, and I do NOT
+# want Sphinx and its 15+ deps as a dep for this build. So:
+cp -r $CWD/man doc/_build
+
make LIBDIR=/usr/lib$LIBDIRSUFFIX
make install LIBDIR=/usr/lib$LIBDIRSUFFIX MANPREFIX=/usr/man DESTDIR=$PKG RSTTOMAN=""
gzip $PKG/usr/man/man?/*.?
@@ -143,6 +155,13 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Include the API docs. Sphinx would be needed to build HTML or PDF docs, but
+# the doc sources are RST, which are perfectly human-readable already (though
+# less easy to navigate).
+cd doc
+rm -rf installation man _build [A-Z]* *.mk *.py *.txt
+cp -a * $PKG/usr/doc/$PRGNAM-$VERSION
+
# Now build the plugin.
cd $TMP