summaryrefslogtreecommitdiffstats
path: root/perl
diff options
context:
space:
mode:
Diffstat (limited to 'perl')
-rw-r--r--perl/perl-Module-Install/README8
-rw-r--r--perl/perl-Module-Install/perl-Module-Install.SlackBuild100
-rw-r--r--perl/perl-Module-Install/perl-Module-Install.info10
-rw-r--r--perl/perl-Module-Install/slack-desc19
4 files changed, 137 insertions, 0 deletions
diff --git a/perl/perl-Module-Install/README b/perl/perl-Module-Install/README
new file mode 100644
index 0000000000..bb2574e3e9
--- /dev/null
+++ b/perl/perl-Module-Install/README
@@ -0,0 +1,8 @@
+perl-Module-Install (Standalone, extensible Perl module installer).
+
+Module::Install is a package for writing installers for CPAN (or CPAN-like) distributions that are clean,
+simple, minimalist, act in a strictly correct manner with ExtUtils::MakeMaker, and will run on any Perl installation version 5.005 or newer.
+
+The intent is to make it as easy as possible for CPAN authors (and especially for first-time CPAN authors)
+to have installers that follow all the best practices for distribution installation, but involve as much
+DWIM (Do What I Mean) as possible when writing them.
diff --git a/perl/perl-Module-Install/perl-Module-Install.SlackBuild b/perl/perl-Module-Install/perl-Module-Install.SlackBuild
new file mode 100644
index 0000000000..a0c62feb27
--- /dev/null
+++ b/perl/perl-Module-Install/perl-Module-Install.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/sh
+#
+# Slackware build script for perl-Module-Install.
+#
+# Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=perl-Module-Install
+VERSION=${VERSION:-1.16}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+perl Makefile.PL \
+ PREFIX=/usr \
+ INSTALLDIRS=vendor \
+ INSTALLVENDORMAN3DIR=/usr/man/man3
+make
+make test
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/share/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
+
+find $PKG -depth -type d -empty -delete || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a Changes README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/perl/perl-Module-Install/perl-Module-Install.info b/perl/perl-Module-Install/perl-Module-Install.info
new file mode 100644
index 0000000000..f554fe1058
--- /dev/null
+++ b/perl/perl-Module-Install/perl-Module-Install.info
@@ -0,0 +1,10 @@
+PRGNAM="perl-Module-Install"
+VERSION="1.16"
+HOMEPAGE="https://metacpan.org/pod/Module::Install"
+DOWNLOAD="https://cpan.metacpan.org/authors/id/E/ET/ETHER/Module-Install-1.16.tar.gz"
+MD5SUM="daec67c3950dcecaa155389b9bdfc1ed"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="perl-Parse-CPAN-Meta perl-YAML-Tiny perl-File-Remove"
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/perl/perl-Module-Install/slack-desc b/perl/perl-Module-Install/slack-desc
new file mode 100644
index 0000000000..e651dd3040
--- /dev/null
+++ b/perl/perl-Module-Install/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+perl-Module-Install: perl-Module-Install (Standalone, extensible Perl module installer).
+perl-Module-Install:
+perl-Module-Install: Module::Install is a package for writing installers for CPAN
+perl-Module-Install: (or CPAN-like) distributions that are clean, simple, minimalist, act
+perl-Module-Install: in a strictly correct manner with ExtUtils::MakeMaker, and will run
+perl-Module-Install: on any Perl installation version 5.005 or newer.
+perl-Module-Install:
+perl-Module-Install: Home page: https://metacpan.org/pod/Module::Install
+perl-Module-Install:
+perl-Module-Install:
+perl-Module-Install: