summaryrefslogtreecommitdiffstats
path: root/python/Flask
diff options
context:
space:
mode:
Diffstat (limited to 'python/Flask')
-rw-r--r--python/Flask/Flask.SlackBuild43
-rw-r--r--python/Flask/Flask.info8
2 files changed, 20 insertions, 31 deletions
diff --git a/python/Flask/Flask.SlackBuild b/python/Flask/Flask.SlackBuild
index 25a68fd471..220eb15946 100644
--- a/python/Flask/Flask.SlackBuild
+++ b/python/Flask/Flask.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Flask
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2021 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -25,11 +25,13 @@
# 20220512 46and2: Updated version, new maintainer.
# - Fix REQUIRES
+# 20230914 46and2: Updated version, change build process.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Flask
-VERSION=${VERSION:-2.1.2}
+SRCNAM=flask
+VERSION=${VERSION:-3.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -42,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -54,43 +53,33 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# relax version required
+sed -i '/Jinja/ s/3\.1\.2/3.0.3/' pyproject.toml
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst CHANGES.rst LICENSE.rst PKG-INFO docs/*.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md CHANGES.rst LICENSE.txt PKG-INFO docs/*.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/Flask/Flask.info b/python/Flask/Flask.info
index c2fb3a93ec..e7c461e8ad 100644
--- a/python/Flask/Flask.info
+++ b/python/Flask/Flask.info
@@ -1,10 +1,10 @@
PRGNAM="Flask"
-VERSION="2.1.2"
+VERSION="3.0.3"
HOMEPAGE="http://flask.pocoo.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask/Flask-2.1.2.tar.gz"
-MD5SUM="93f1832e5be704ef6ff2a4124579cd85"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask/flask-3.0.3.tar.gz"
+MD5SUM="4658b022a07f6d8df51ef24c717fe162"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="werkzeug python3-itsdangerous click python-importlib_metadata"
+REQUIRES="werkzeug python3-itsdangerous click python3-blinker python-importlib_metadata"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"