summaryrefslogtreecommitdiffstats
path: root/python/Markdown/Markdown.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/Markdown/Markdown.SlackBuild')
-rw-r--r--python/Markdown/Markdown.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/Markdown/Markdown.SlackBuild b/python/Markdown/Markdown.SlackBuild
index 80c35c53bc..5441fcdfad 100644
--- a/python/Markdown/Markdown.SlackBuild
+++ b/python/Markdown/Markdown.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Markdown
-# Copyright 2013-2016 Markus Reichelt, Aachen, DE
+# Copyright 2013-2019 Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=Markdown
-VERSION=${VERSION:-2.6.6}
+VERSION=${VERSION:-2.6.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true