summaryrefslogtreecommitdiffstats
path: root/python/MarkupSafe/MarkupSafe.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/MarkupSafe/MarkupSafe.SlackBuild')
-rw-r--r--python/MarkupSafe/MarkupSafe.SlackBuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/python/MarkupSafe/MarkupSafe.SlackBuild b/python/MarkupSafe/MarkupSafe.SlackBuild
index 5886323cbc..3302f10731 100644
--- a/python/MarkupSafe/MarkupSafe.SlackBuild
+++ b/python/MarkupSafe/MarkupSafe.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for MarkupSafe
-# Copyright 2010-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2010-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=MarkupSafe
-VERSION=${VERSION:-0.23}
+VERSION=${VERSION:-1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
@@ -63,17 +63,17 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG --no-compile
-if $(python3 -c 'import setuptools' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
CFLAGS="$SLKCFLAGS" \
python3 setup.py install --root=$PKG --no-compile
fi
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION