summaryrefslogtreecommitdiffstats
path: root/python/boto
diff options
context:
space:
mode:
Diffstat (limited to 'python/boto')
-rw-r--r--python/boto/README2
-rw-r--r--python/boto/boto.SlackBuild4
-rw-r--r--python/boto/boto.info6
3 files changed, 6 insertions, 6 deletions
diff --git a/python/boto/README b/python/boto/README
index f779e1a348..c097a5f87a 100644
--- a/python/boto/README
+++ b/python/boto/README
@@ -5,5 +5,5 @@ Services. In addition, boto provides support for other public services such as
Google Storage in addition to private cloud systems like Eucalyptus, OpenStack
and Open Nebula.
-Optional dependencies: simplejson, filechunkio, lxml and keyring (this last
+Optional dependencies: filechunkio, lxml and keyring (this last one
isn't yet available on SlackBuilds.org).
diff --git a/python/boto/boto.SlackBuild b/python/boto/boto.SlackBuild
index 6d336a6e0c..d0a234ddcf 100644
--- a/python/boto/boto.SlackBuild
+++ b/python/boto/boto.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=boto
-VERSION=${VERSION:-2.16.0}
+VERSION=${VERSION:-2.34.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -58,7 +58,7 @@ find -L . \
python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a Changelog.rst PKG-INFO README.rst docs/*.pdf $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst docs/*.pdf docs/*/*/v${VERSION}.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README.$PRGNAM > $PKG/usr/doc/$PRGNAM-$VERSION/README.$PRGNAM
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/boto/boto.info b/python/boto/boto.info
index 6bfb59c926..cf22de81ae 100644
--- a/python/boto/boto.info
+++ b/python/boto/boto.info
@@ -1,8 +1,8 @@
PRGNAM="boto"
-VERSION="2.16.0"
+VERSION="2.34.0"
HOMEPAGE="https://github.com/boto/boto"
-DOWNLOAD="http://pypi.python.org/packages/source/b/boto/boto-2.16.0.tar.gz"
-MD5SUM="9399feb58b1fbf1f85ce13ddd10e904a"
+DOWNLOAD="http://pypi.python.org/packages/source/b/boto/boto-2.34.0.tar.gz"
+MD5SUM="5556223d2d0cc4d06dd4829e671dcecd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python-requests paramiko rsa PyYAML simplejson"