summaryrefslogtreecommitdiffstats
path: root/python/feedparser
diff options
context:
space:
mode:
Diffstat (limited to 'python/feedparser')
-rw-r--r--python/feedparser/README1
-rw-r--r--python/feedparser/feedparser.SlackBuild38
-rw-r--r--python/feedparser/feedparser.info8
3 files changed, 9 insertions, 38 deletions
diff --git a/python/feedparser/README b/python/feedparser/README
index 0f7ef1c4a5..74539768b3 100644
--- a/python/feedparser/README
+++ b/python/feedparser/README
@@ -1 +1,2 @@
feedparser is a Python utility library to parse RSS and Atom feeds.
+
diff --git a/python/feedparser/feedparser.SlackBuild b/python/feedparser/feedparser.SlackBuild
index d777317ae2..0b37c60099 100644
--- a/python/feedparser/feedparser.SlackBuild
+++ b/python/feedparser/feedparser.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for feedparser
# Modified by Luis Henrique <lmello.009@gmail.com>
-# Maintained 2014-2019 by Christoph Willing <chris.willing@linux.com>
+# Maintained 2014-2023 by Christoph Willing <chris.willing@linux.com>
# Copyright 2008-2009 Chess Griffin <chess@chessgriffin.com>
# All rights reserved.
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=feedparser
-VERSION=${VERSION:-5.2.1}
+VERSION=${VERSION:-6.0.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -54,20 +51,6 @@ OUTPUT=${OUTPUT:-/tmp}
DOCS="LICENSE NEWS README.rst"
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -83,21 +66,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build
-python setup.py install --root $PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- # Python3 doesn't have sgmllib so we provide it here for building
- # and later installation as part of the feedparser package.
- cp feedparser/sgmllib3.py feedparser/sgmllib.py
- PYTHONPATH=$(pwd)/feedparser:$PYTHONPATH
-
- patch -p0 < $CWD/001_py37.diff
- python3 setup.py build
- python3 setup.py install --root $PKG
-
- PYSITEDIR=$(python3 -c "import site; print(site.getsitepackages()[0])")
- install -m 0644 feedparser/sgmllib.py $PKG/$PYSITEDIR
-fi
+python3 setup.py build
+python3 setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/feedparser/feedparser.info b/python/feedparser/feedparser.info
index fe8c8895d9..1fd13c9066 100644
--- a/python/feedparser/feedparser.info
+++ b/python/feedparser/feedparser.info
@@ -1,10 +1,10 @@
PRGNAM="feedparser"
-VERSION="5.2.1"
+VERSION="6.0.11"
HOMEPAGE="https://github.com/kurtmckee/feedparser"
-DOWNLOAD="https://github.com/kurtmckee/feedparser/archive/5.2.1/feedparser-5.2.1.tar.gz"
-MD5SUM="885d800496ffd538920960b9dbc45faf"
+DOWNLOAD="https://github.com/kurtmckee/feedparser/archive/6.0.11/feedparser-6.0.11.tar.gz"
+MD5SUM="bbb8814240ef30c930ad8ea8eeb8e80b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-sgmllib3k"
MAINTAINER="Christoph Willing"
EMAIL="chris.willing@linux.com"