summaryrefslogtreecommitdiffstats
path: root/python/flake8/flake8.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/flake8/flake8.SlackBuild')
-rw-r--r--python/flake8/flake8.SlackBuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/python/flake8/flake8.SlackBuild b/python/flake8/flake8.SlackBuild
index 6a9f487fd6..2c731b46d3 100644
--- a/python/flake8/flake8.SlackBuild
+++ b/python/flake8/flake8.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for flake8
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=flake8
-VERSION=${VERSION:-3.5.0}
+VERSION=${VERSION:-7.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,10 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Ignores setuptools version, it works for me
-sed -i "s/setuptools >= 30\",/\"/" setup.py
-
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -93,7 +90,6 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE