summaryrefslogtreecommitdiffstats
path: root/python/git-fame/git-fame.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/git-fame/git-fame.SlackBuild')
-rw-r--r--python/git-fame/git-fame.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/git-fame/git-fame.SlackBuild b/python/git-fame/git-fame.SlackBuild
index 4ac22ea1bf..b3204c85b2 100644
--- a/python/git-fame/git-fame.SlackBuild
+++ b/python/git-fame/git-fame.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for git-fame
-# Copyright 2017 Andrew Clemons, Wellington New Zealand
+# Copyright 2017-2018 Andrew Clemons, Wellington New Zealand
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=git-fame
-VERSION=${VERSION:-1.3.0}
+VERSION=${VERSION:-1.4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -74,6 +74,9 @@ python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/share/bash-completion/completions
install -m 644 git-fame_completion.bash $PKG/usr/share/bash-completion/completions/git-fame