summaryrefslogtreecommitdiffstats
path: root/python/git-fame/git-fame.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/git-fame/git-fame.SlackBuild')
-rw-r--r--python/git-fame/git-fame.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/python/git-fame/git-fame.SlackBuild b/python/git-fame/git-fame.SlackBuild
index 7951b0dff4..fd4685bdd6 100644
--- a/python/git-fame/git-fame.SlackBuild
+++ b/python/git-fame/git-fame.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for git-fame
# Copyright 2017-2021 Andrew Clemons, Wellington New Zealand
+# Copyright 2022-2023 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=git-fame
-VERSION=${VERSION:-1.15.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.0.1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,7 +77,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true