summaryrefslogtreecommitdiffstats
path: root/python/hpack/hpack.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/hpack/hpack.SlackBuild')
-rw-r--r--python/hpack/hpack.SlackBuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/python/hpack/hpack.SlackBuild b/python/hpack/hpack.SlackBuild
index c6afe2570d..67d45a08d5 100644
--- a/python/hpack/hpack.SlackBuild
+++ b/python/hpack/hpack.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for hpack
-# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2016 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=hpack
-VERSION=${VERSION:-2.0.1}
+VERSION=${VERSION:-2.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -71,11 +71,18 @@ find -L . \
python setup.py install --root=$PKG
+# Manually generated with Sphinx
+# Recreate man page each hpack update
+install -Dm 644 $CWD/man_page/hpack.1 $PKG/usr/man/man1/hpack.1
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CONTRIBUTORS.rst LICENSE PKG-INFO HISTORY.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CONTRIBUTORS.rst LICENSE HISTORY.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install