summaryrefslogtreecommitdiffstats
path: root/python/httplib2/use_system_cacerts.patch
diff options
context:
space:
mode:
Diffstat (limited to 'python/httplib2/use_system_cacerts.patch')
-rw-r--r--python/httplib2/use_system_cacerts.patch55
1 files changed, 31 insertions, 24 deletions
diff --git a/python/httplib2/use_system_cacerts.patch b/python/httplib2/use_system_cacerts.patch
index d2def9dad8..7f58da2992 100644
--- a/python/httplib2/use_system_cacerts.patch
+++ b/python/httplib2/use_system_cacerts.patch
@@ -1,13 +1,20 @@
-Description: Use system ca certificates, not the bundled ones
-Author: Marc Deslauriers <marc.deslauriers@canonical.com>
+From: Marc Deslauriers <marc.deslauriers@canonical.com>
+Date: Wed, 5 Sep 2018 14:02:17 +0800
+Subject: Use system ca certificates, not the bundled ones
+
Forwarded: not-needed
Bug-Ubuntu: https://launchpad.net/bugs/882027
+---
+ python2/httplib2/__init__.py | 5 ++---
+ python3/httplib2/__init__.py | 5 ++---
+ setup.py | 1 -
+ 3 files changed, 4 insertions(+), 7 deletions(-)
-Index: b/python2/httplib2/__init__.py
-===================================================================
---- a/python2/httplib2/__init__.py 2013-03-18 22:37:43.423868573 +0100
-+++ b/python2/httplib2/__init__.py 2013-03-18 22:37:43.419868572 +0100
-@@ -190,9 +190,8 @@
+diff --git a/python2/httplib2/__init__.py b/python2/httplib2/__init__.py
+index 18b013d..8b9a8c0 100644
+--- a/python2/httplib2/__init__.py
++++ b/python2/httplib2/__init__.py
+@@ -217,9 +217,8 @@ try:
import ca_certs_locater
CA_CERTS = ca_certs_locater.get()
except ImportError:
@@ -19,11 +26,11 @@ Index: b/python2/httplib2/__init__.py
# Which headers are hop-by-hop headers by default
HOP_BY_HOP = ['connection', 'keep-alive', 'proxy-authenticate', 'proxy-authorization', 'te', 'trailers', 'transfer-encoding', 'upgrade']
-Index: b/python3/httplib2/__init__.py
-===================================================================
---- a/python3/httplib2/__init__.py 2013-03-18 22:37:43.423868573 +0100
-+++ b/python3/httplib2/__init__.py 2013-03-18 22:37:43.419868572 +0100
-@@ -123,9 +123,8 @@
+diff --git a/python3/httplib2/__init__.py b/python3/httplib2/__init__.py
+index 5dae2a5..8c63925 100644
+--- a/python3/httplib2/__init__.py
++++ b/python3/httplib2/__init__.py
+@@ -124,9 +124,8 @@ DEFAULT_MAX_REDIRECTS = 5
# Which headers are hop-by-hop headers by default
HOP_BY_HOP = ['connection', 'keep-alive', 'proxy-authenticate', 'proxy-authorization', 'te', 'trailers', 'transfer-encoding', 'upgrade']
@@ -33,17 +40,17 @@ Index: b/python3/httplib2/__init__.py
+# Use system CA certificates
+CA_CERTS = "/etc/ssl/certs/ca-certificates.crt"
- def _get_end2end_headers(response):
- hopbyhop = list(HOP_BY_HOP)
-Index: b/setup.py
-===================================================================
---- a/setup.py 2013-03-18 22:37:43.423868573 +0100
-+++ b/setup.py 2013-03-18 22:37:43.419868572 +0100
-@@ -62,7 +62,6 @@
- """,
- package_dir=pkgdir,
- packages=['httplib2'],
-- package_data={'httplib2': ['*.txt']},
- classifiers=[
+ # PROTOCOL_TLS is python 3.5.3+. PROTOCOL_SSLv23 is deprecated.
+ # Both PROTOCOL_TLS and PROTOCOL_SSLv23 are equivalent and means:
+diff --git a/setup.py b/setup.py
+index 0f3a516..9c07bc2 100755
+--- a/setup.py
++++ b/setup.py
+@@ -58,7 +58,6 @@ A comprehensive HTTP client library, ``httplib2`` supports many features left ou
+ """,
+ package_dir=pkgdir,
+ packages=['httplib2'],
+- package_data={'httplib2': ['*.txt']},
+ classifiers=(
'Development Status :: 4 - Beta',
'Environment :: Web Environment',