summaryrefslogtreecommitdiffstats
path: root/python/josepy/josepy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/josepy/josepy.SlackBuild')
-rw-r--r--python/josepy/josepy.SlackBuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/python/josepy/josepy.SlackBuild b/python/josepy/josepy.SlackBuild
index ad5a4f2fa1..215e161da8 100644
--- a/python/josepy/josepy.SlackBuild
+++ b/python/josepy/josepy.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for josepy
-# Copyright 2018-2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2018-2023 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=josepy
-VERSION=${VERSION:-1.8.0}
+VERSION=${VERSION:-1.14.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,11 +76,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true