summaryrefslogtreecommitdiffstats
path: root/python/lxml/lxml.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/lxml/lxml.SlackBuild')
-rw-r--r--python/lxml/lxml.SlackBuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/python/lxml/lxml.SlackBuild b/python/lxml/lxml.SlackBuild
index df1ee9fe02..ed6222ed25 100644
--- a/python/lxml/lxml.SlackBuild
+++ b/python/lxml/lxml.SlackBuild
@@ -68,10 +68,8 @@ find -L . \
python2 setup.py build --with-unicode-strings
python2 setup.py install --skip-build --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py build --with-unicode-strings
- python3 setup.py install --skip-build --root=$PKG
-fi
+python3 setup.py build --with-unicode-strings
+python3 setup.py install --skip-build --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true