summaryrefslogtreecommitdiffstats
path: root/python/lxml
diff options
context:
space:
mode:
Diffstat (limited to 'python/lxml')
-rw-r--r--python/lxml/README7
-rw-r--r--python/lxml/lxml.SlackBuild86
-rw-r--r--python/lxml/lxml.info10
-rw-r--r--python/lxml/slack-desc19
4 files changed, 0 insertions, 122 deletions
diff --git a/python/lxml/README b/python/lxml/README
deleted file mode 100644
index a038bd0592..0000000000
--- a/python/lxml/README
+++ /dev/null
@@ -1,7 +0,0 @@
-lxml is a Pythonic binding for the libxml2 and libxslt libraries.
-It is unique in that it combines the speed and feature completeness
-of these libraries with the simplicity of a native Python API.
-
-Optional dependencies: BeautifulSoup and cssselect
-
-BeautifulSoup can be used in place of BeautifulSoup4.
diff --git a/python/lxml/lxml.SlackBuild b/python/lxml/lxml.SlackBuild
deleted file mode 100644
index 87681482a7..0000000000
--- a/python/lxml/lxml.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for lxml
-
-# Copyright 2009-2019 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=lxml
-VERSION=${VERSION:-4.4.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-else
- SLKCFLAGS="-O2"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py build --with-unicode-strings
-python2 setup.py install --skip-build --root=$PKG
-
-python3 setup.py build --with-unicode-strings
-python3 setup.py install --skip-build --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt doc/licenses/* doc/FAQ.txt $PKG/usr/doc/$PRGNAM-$VERSION
-rm $PKG/usr/doc/$PRGNAM-$VERSION/version.txt
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/lxml/lxml.info b/python/lxml/lxml.info
deleted file mode 100644
index 564d80a926..0000000000
--- a/python/lxml/lxml.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="lxml"
-VERSION="4.4.1"
-HOMEPAGE="https://lxml.de/"
-DOWNLOAD="https://pypi.io/packages/source/l/lxml/lxml-4.4.1.tar.gz"
-MD5SUM="ce976a2d3c630d7fde86d3a4c3a1c606"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="BeautifulSoup4 html5lib"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/lxml/slack-desc b/python/lxml/slack-desc
deleted file mode 100644
index 00f8202cbd..0000000000
--- a/python/lxml/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-lxml: lxml (Python bindings for libxml2 and libxslt)
-lxml:
-lxml: lxml is a Pythonic binding for the libxml2 and libxslt libraries. It
-lxml: is unique in that it combines the speed and feature completeness of
-lxml: these libraries with the simplicity of a native Python API.
-lxml:
-lxml: Homepage: https://lxml.de/
-lxml:
-lxml:
-lxml:
-lxml: