summaryrefslogtreecommitdiffstats
path: root/python/netifaces
diff options
context:
space:
mode:
Diffstat (limited to 'python/netifaces')
-rw-r--r--python/netifaces/README2
-rw-r--r--python/netifaces/netifaces.SlackBuild28
-rw-r--r--python/netifaces/netifaces.info6
3 files changed, 30 insertions, 6 deletions
diff --git a/python/netifaces/README b/python/netifaces/README
index 008cffeaeb..4c622be1e5 100644
--- a/python/netifaces/README
+++ b/python/netifaces/README
@@ -1 +1,3 @@
Portable module to access network interface information in Python.
+
+python3 is an optional dependency.
diff --git a/python/netifaces/netifaces.SlackBuild b/python/netifaces/netifaces.SlackBuild
index 6164899bd3..d2641cc9ac 100644
--- a/python/netifaces/netifaces.SlackBuild
+++ b/python/netifaces/netifaces.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for netifaces
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=netifaces
-VERSION=${VERSION:-0.8}
+VERSION=${VERSION:-0.10.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,11 +57,15 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import setuptools' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/netifaces/netifaces.info b/python/netifaces/netifaces.info
index bd32a1769a..115f069609 100644
--- a/python/netifaces/netifaces.info
+++ b/python/netifaces/netifaces.info
@@ -1,8 +1,8 @@
PRGNAM="netifaces"
-VERSION="0.8"
+VERSION="0.10.4"
HOMEPAGE="http://alastairs-place.net/projects/netifaces/"
-DOWNLOAD="http://alastairs-place.net/projects/netifaces/netifaces-0.8.tar.gz"
-MD5SUM="e57e5983f4c286fac5f8068fbfc5c873"
+DOWNLOAD="https://pypi.python.org/packages/source/n/netifaces/netifaces-0.10.4.tar.gz"
+MD5SUM="36da76e2cfadd24cc7510c2c0012eb1e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools"