summaryrefslogtreecommitdiffstats
path: root/python/nxt-python
diff options
context:
space:
mode:
Diffstat (limited to 'python/nxt-python')
-rw-r--r--python/nxt-python/70-lego.rules1
-rw-r--r--python/nxt-python/README38
-rw-r--r--python/nxt-python/nxt-python.SlackBuild72
-rw-r--r--python/nxt-python/nxt-python.info10
-rw-r--r--python/nxt-python/slack-desc19
5 files changed, 0 insertions, 140 deletions
diff --git a/python/nxt-python/70-lego.rules b/python/nxt-python/70-lego.rules
deleted file mode 100644
index 36499b5ddf..0000000000
--- a/python/nxt-python/70-lego.rules
+++ /dev/null
@@ -1 +0,0 @@
-SUBSYSTEM=="usb", ATTRS{idVendor}=="0694", GROUP="lego", MODE="0660" \ No newline at end of file
diff --git a/python/nxt-python/README b/python/nxt-python/README
deleted file mode 100644
index ebba712129..0000000000
--- a/python/nxt-python/README
+++ /dev/null
@@ -1,38 +0,0 @@
-nxt-python (python module to control Lego NXT)
-
-nxt-python is a python 2.x driver/interface for the Lego Mindstorms
-NXT robot. Development for this has stalled, so there is no
-[complete] Python3 implementation.
-
-Setup
-------
-
-In order to use nxt-python with an NXT kit, you should add a 'lego'
-group to your system, and add yourself to that group:
-
- # groupadd lego
- # usermod -a -G lego YourUserName
-
-You will also want to set up a udev rule to identify NXT hardware and
-grant the 'lego' group permission to use it.
-
-A sample rule is included for you in /usr/share/nxt-python, but you may
-want to verify the vendor code of the NXT unit.
-
-To verify the vendor code, connect the NXT hardware to your computer
-and then run:
-
- # lsusb
-
-Look at the ID for the Lego device; it will probably be 0694, but if not,
-then change the value in the sample udev rule to match.
-
-Save the sample udev rule (70-lego.rules) to /etc/udev/rules.d/
-
-Log out and log back in, and you should now have full control, via Python,
-over your NXT hardware.
-
-Requires at least one of these
--------------------------------
-pyusb (for USB communication)
-pybluez (for bluetooth communication)
diff --git a/python/nxt-python/nxt-python.SlackBuild b/python/nxt-python/nxt-python.SlackBuild
deleted file mode 100644
index 1794be8025..0000000000
--- a/python/nxt-python/nxt-python.SlackBuild
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for nxt-python
-# Copyright 2014 klaatu @member.fsf.org
-
-# GNU All-Permissive License
-# Copying and distribution of this file, with or without modification,
-# are permitted in any medium without royalty provided the copyright
-# notice and this notice are preserved. This file is offered as-is,
-# without any warranty.
-
-PRGNAM=nxt-python
-VERSION=${VERSION:-2.2.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
-cp -ar examples $CWD/70-lego.rules $PKG/usr/share/$PRGNAM-$VERSION
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/nxt-python/nxt-python.info b/python/nxt-python/nxt-python.info
deleted file mode 100644
index c0554514c3..0000000000
--- a/python/nxt-python/nxt-python.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="nxt-python"
-VERSION="2.2.2"
-HOMEPAGE="https://github.com/Eelviny/nxt-python"
-DOWNLOAD="https://github.com/Eelviny/nxt-python/archive/v2.2.2/nxt-python-2.2.2.tar.gz"
-MD5SUM="5bd1f018cef143f3c1184847db6a9e1e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pyusb pybluez"
-MAINTAINER="klaatu"
-EMAIL="klaatu@member.fsf.org"
diff --git a/python/nxt-python/slack-desc b/python/nxt-python/slack-desc
deleted file mode 100644
index 596d17f356..0000000000
--- a/python/nxt-python/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-nxt-python: nxt-python (python module to control Lego NXT)
-nxt-python:
-nxt-python: nxt-python is a python driver/interface for the Lego Mindstorms NXT
-nxt-python: robot.
-nxt-python:
-nxt-python: http://code.google.com/p/nxt-python/
-nxt-python:
-nxt-python:
-nxt-python:
-nxt-python:
-nxt-python: